Apple TV question

Thanks, I’ll check the serial # in the morning.

Well, installed my new RT-N66U and it worked. Kinda.

Installed the new ASUS router, configured it with defaults including WPA2 Personal/AES wireless security. Went into my Apple TV, logged into the new router/network, and my computer’s iTunes showed up under Computer. Yes! Success!

But - it was slowwwwwww. Whether I was going to the iTunes store, Netflix, my computer’s iTunes, it was slow. I picked a song to play, and it sat for a minute or so loading it. Gave up, tried other things, all too slow. Restarted the Apple TV. Then my computer no longer showed up under Computer, back to “Turn on Home Sharing.” Argh.

So, just for trying something, I noticed that the ASUS 5G wireless network was accessible from the Apple TV, so I logged into it. Success. Computer shows up under Computer, speeds are good ( shows my wireless speeds in the room clocking in at 15 M down/1 M up.) Not sure why it is working so much better once I logged into the 5GHz wireless network, and maybe later I’ll try relogging into the regular one (2.5 GHz?) but for now it works.

hmm or you could have lots of 2.4g congestion.

Yeah, but wonder why it would only show up on the Apple TV? Everything else is really, really quick (Laptop, Xbox - that’s it other than Apple TV.)

so is the serial number of yours affected by recall?

I had something similar (I’m wired into the internet I believe, but was trying to stream rips from my computer over wireless) and the difficulty turned out to be the network sharing bandwidth for 802.11g/n. For whatever reason this made the AppleTV not work streaming HD stuff (10 minutes to buffer a 30s clip or so) and even music/SD video would take forever to start and often stop to buffer. When I switched my network to 100% 802.11n all this went away. I only really saw this issue on the AppleTV (though switching over did kill the ability of my old laptop to connect to wireless at all; s’fine, we needed a new machine for my wife to play BigFish games on anyway!).

It should be noted that the link you pointed to says it’s the 3rd & 4th number for the check, but it’s actually the 4th and 5th. And apparently my unit is affected, which may explain the above referenced bad behavior.

Oh oh…I’ve had to ‘reboot’ my ATV a few times due to connectivity issues. I shall have to see if mine is available for recall.

Make sure you flash the latest firmware on the asus and do a factory reset.
Set a manual channel for 2.4 ghz instead of auto.
I would use 5ghz anyways if it is available.
Go to the advance page for wireless and bump tx power to 200.

Nope, my last 4 aren’t anywhere similar to DRHN.