Armageddon Empires

It’s got that similar evocative crazy vibe nobody can tell whence it comes from. And also an obtuse UI that hides away most of the incredible things you can do in the game (at first glance, it will look like you can do practically nothing, so check a tutorial out!)

If someone made a boardgame based on Shadow Empire, it might resemble Armageddon Empires.

Post apocalyptic desert landscape where humans, mutants, aliens and killer robots fight it out in a card driven mini-4x - with copious references to pop/pulp fiction (such as snake plisskin and mad Max).

IIRC a game should take an hour or two; it’s basically about finding and destroying the other headquarter(s) whilst protecting yours.

It’s a great great game, with a lot of clever ideas in a clunky package: The UI takes some getting used to and the first few games will be confusing…but it is quite a straight forward game at heart.

Wow, great to have this one accessible on Steam. I have an old school digital copy kicking around somewhere. Perhaps other Cryptic Comet titles are on the way?

Holy cow, AE is on Steam now?! Thanks for sharing that, I loved this one.

For you kids too young to remember the original, I came across this bit of Tomsplaining:

For clarification – this IS “the original,” right? Were any significant changes to the game made that would impact play? It’s my understanding that this is same game, different store (potentially including pesky DRM), but please correct me if I’m wrong. $8.99 hangs in the balance!

Yes it is the original.

Bought, installed, and I’m having a problem running it. At Vic’s suggestion I’m running it in Windowed mode, but no matter what compatibility setting I try, the top and bottom are cut off, making the game unplayable. This at 1920x1080

I’ve already posted this in the Steam forum, but perhaps Vic will see it here first. Or maybe someone else has an idea.

sounds like a monitor issue? It seems it zooms the 4:3 to 16:9, tronking upper and dow parts. Probably can be checked in display properties or video drivers, or in the monitor’s settings themselves

2018? Tom was way late to the party.

If you had watched it, you’d know he refrained to publish it for 11 years, because streaming hadn’t caught on.

So for those of us less technically inclined, what would be the fix? Video card is Geforce 1060 TI, btw

Can’t help much, I know next to nothing about Windows!
You could check your monitor’s manual to check if there is a setting about auto cropping or such for 4:3 resolutions.
Although all this shouldn’t be an issue if you run the game in a window as Vic suggested. You are in trouble, I think.

Edit: I checked a bit, and it seems you can’t crope the way you’re experiencing it from Windows itself, so maybe it’s really related to the way your monitor scales the game?

Hey Sonoftgb,
Sorry about this. Director is wacky sometimes for no good reason. Are you saying that you get the window, but the display inside is not aligned properly. Like it’s to big for the small window and is getting clipped?

I take it you are running it in Admin mode?

Also, you can try running the full screen version and see how it looks. Maybe lower your display resolution first. That will be a pain but might help. The full screen .exe is in the steam folder that gets installed in Steam/SteamApps/Common/etc

Hope this helps.

Vic -

Yes and yes. I tried the full screen .exe, and that was cropped even worse, on the left and right sides.

I could try dropping the resolution and see if that helps.

And Left_Empty, it’s a laptop so no monitor manual to speak of.

I’ve tried several different resolutions and whether full screen or windowed it’s cut off. Rats.

Guilty!

I’m thinking, something very stupid: could it be related to the DPI settings thing of Windows 10?

Go to System/Display settings, and make sure your scale under scale and layout is at 100% (here, at 150%, it exhibits the kind of glitches you are seeing, is why I am asking).
The problem is that all the fonts of the system will show smaller and might get hard to read, especially on a laptop screen. But in my experience, higher scaling can lead to some glitches in games.

It might be greyed out: here to be able to modify it to test my theory, I had to type “DPI” in the search bar on the left, and click on “Make everything bigger” to tweak it.

That’s it! I was having problems with my vision last year and had it set to 150%. Reducing it to the recommended 125% solved the problem.

Thanks