Assassin's Creed Valhalla

As of the last patch, Zealots have a set starting level, but if you out-level their starting level, they scale to your higher level.

I am having a nightmare, I have just finished the 1st three zones and get the Valka bug, I am now level 55 and accept the 4th section East Anglia and then Valka arrives and she gets stuck on the way to her Tent as I escort her, i Have tried all the fixes including going back 3 hours and still cannot get her to move to her tent.

Means I cannot move the game on, really frustrating, I was at 21 hours but am now trying from 16 hours in again to see if I can un bug it by do9ing it all again in a different order.

Issue here if anyone else has had it and managed to get passed it

A Wise Friend

The best thing to use against zealots is the passive skill that slows time when you dodge. You basically get a perfect tactic against them: dodge all the time and eventually you dodge their hard attack triggering a matrix time. You get a couple of attacks this way. The only problem is restoring stamina but as long as zealot is alone it should be easy.

Wow. That sounds frustrating. I’ve only had one NPC get stuck once in over 100 hours of play (the sister of the hunter) and a reload took care of that.

May I assume you continued on to the tent without her following and she didn’t teleport there? Also, you could try raiding an abbey and trying to build her tent into her house immediately. If it works, it might force her to teleport inside?

Yep. That’s by far my favourite skill against them, the beast hunts and bosses.

I felt the same way, but it gets a lot easier. Unlocking a few more abilities on the skill tree like counter on parry (you can only parry the golden attacks, not the red ones), slow time on dodge (dodge the red attacks), stun finishers, and a few upgrades on your book-abilities. You’ll get there :)

I’d try ignoring Valka and moving on with the main story, it seems every time you finish a main story arc, things like this reset in the settlement.
I have an issue with the yule ale-mission, where the game doesn’t acknowledge that I’ve picked the keg up so I can’t deliver it. But every time i progress in the main story (report back to Randvi) - the quest resets and I can start it again back in the settlement. You could try that?

Fucking Yule vendor disappeared. Happening to lots of people. Ubi shrugs…

The whole Yule festival is seriously buggy.

Thanks I will give that a go, I tried going back to before completing the 3rd region and doing it all again and upgrading the house etc etc but still bugged, maybe just doing the next zone will un bug it.

I made myself uninstall after 163 hours so I can play other stuff. Will probably be back for DLC.

I ignored all the Yule stuff though. Frivolous invasion displacing activity!

Yeah I was waiting for a quick patch but nothing. Hustled to collect the full armor before new years so I’m good with that one at least!

This game does seem a lot buggier than Odyssey was at the same stage since release. I crash 1-2 times a session. Sometimes when participating in the Yule fighting event, Eivor is levitating off the ground, still landing punches. Kind of gives a literal meaning to “floating like a butterfly and stinging like a bee”. (Sorry). I am lucky enough to have experienced no progress halting bugs to date. For the opal missions, I learned to only take one at a time as the second one can disappear.

Still, I am around 70 hours with dozens more ahead of me and I am having a great time. I loved Odyssey but I am having more fun in Valhalla, The world seems more fully realized and Eivor has roots in it. Because of that, I am more attached to Eivor than any other Assassin’s Creed character, including Kassandra. And exploring Roman ruins never gets old.

Vendor is back. I got my Seax and every piece of armor. Skipping the shield and tattoos unless someone says I should really get the shield. 70 hours in haven’t used a shield once…

What devicenare you playing on Tohree? It’s the same for me on PS4, lots of bugs and a crash a day.
It seems this is worst for PS4 users and other last gen-devices.

Even with all the bugs tho, I too think this might be the best AC game I ever played.

Can we talk about how great it is to have an upgradeable home base? Why is it so satisfying to have a place to return to and watch it grow. Plus the legendary animal trophies. And my lil fox and wolf running around there (the cat on the ship!)

I started off on the PS4 Pro, thinking that I was going to pick up a PS5 over the holidays. When that didn’t pan out, I did a computer upgrade instead . Playing max detail on a 3080 video card. The game looks great at times.

Yeah, I absolutely love having an upgradeable home base. It is a great way to show your progress. Some of the quests that tie you into your community are clever as well. A couple of them even pop up as contestants in the Yule fighting event.

This is my favorite AC game as well. I like the levelling system and having to find or earn abilities. Combat and stealth feel satisfying as well.

I agree. Contrary to the previous AC games, this is still growing on me (despite its flaws). Not growing tired of it, as I have with the millions of fort clear-outs in both Origins and Odyssey (and clear outs in Syndicate).

Yesterday, I got the Glowcesterscire-bug, namely that the hood you get there gets stuck on you even after returning back to your settlement. I’ve tried spamming the other hoods, equipping different sets and all that. It\s STUCK. Anyone had this and got rid of it?

Yikes! Sorry to hear about your experiences with the cloak bug. I read online that if you access the cloak command when you are mounting your horse, you might be able to remove it and put another one on once you dismount. Not sure if that will work though but it is worth a shot.

Tried the horse / hood, tried changing hair, upgrading a hood while wearing it, changed to male avatar, spammed hoods, removed all clothing, sleeping, reloading, fighting, changing tattoos.

I guess I’m stuck with this

Ugh. Your playthrough is eventful when it comes to bugs. I didn’t get stuck with the disguise, fortunately. On the plus side, you will get lots of treats in other villages?

I had the same issue until I wrapped up that zone’s main quest.

Interesting. I was able to put on and remove that outfit at will after the nightly quest. Was useful to talk to the druid. Annoying that those quest bugs still remain this long after release.