Battletech by Harebrained Schemes (Shadowrun Returns)


#2423

I figured that’s what you meant, but thanks for clarifying.


#2424

Still trucking along, a couple missions per night. I’m running two heavily armored Shadow Hawks who draw fire and use long-range weapons to soften up targets then switch to melee, along with an Enforcer packed to the gills with medium lasers, and an LRM-boat Centurion or Trebuchet.

I’m surprised you guys didn’t prioritize the second mech bay. I just got access to the Argo, and that’s the first thing I went looking for. With only 6 slots, there were too many times where a couple mechs were being repaired and I had to store a newly salvaged mech before I could even look at it (since the mech I wanted to store to make room had minor damage from the last mission, so it couldn’t be stored yet). I wish you could just postpone assembling the 3/3 salvage parts in cases like that.

In fact, I almost lost a salvaged Trebuchet from that bug last night, but fortunately had a backup save where I had put my Centurion into storage to make room instead.


#2425

Regarding upgrades, I see 1 medbay upgrade but it’s already highlighted and I don’t think I was able to upgrade it. Nothing else showing in that section.

Good idea.


#2426

That would be nice, also a button to refit the mech to its standard configuration would be great (as long as the parts are still available). That was probably the biggest annoyance for me of putting a mech in storage. With the extra mech bay vs tech point improvements, I think it came down to cost for me. I was able to benefit from the reduced down time for mechs while getting the cushion to be able to pay the $900,000 for the extra bay.


#2427

Nothing about the prone mech pilot eject crash.


#2428

Does anyone know if multiple melee mods stack?


#2429

I… really don’t know, now that you mention it. Huh. I wouldn’t EXPECT more than one mod per limb to work, but I’ve never tried the above.


#2430

It should. I saw a post exploiting a bug where they stack so many Death from above mods, the mech HEALED doing a DFA.


#2431

I hit a bug where the timeline would not advance. It was stuck on Financian Report (done), and nothing below that (like my repair/refit jobs) would ever advance. I took the opportunity to start over, as I wasn’t super happy with how my mech assortment had wound up. Even though I was at the endgame, I don’t mind.


#2432

I beat the game a week ago, and even though I should be playing Pillars 2 I keep diving back in to Battletech for a few missions because I want to get every mech out there. It’s become a “gotta catch 'em all” pokemon thing for me.


#2433

I’m in the same boat. I really want to get my hands on some the really rare equipment also. I’ve got a Thermal Exchanger unit that drops heat output from all weapons in the mech by 10%. Absolutely rocks for an energy-heavy mech. I’ve heard tell on various forums of Thermal Exchanger + or ++ models as well, which I’d dearly love to get my hands on. Can’t find them to save my life though.

I’m just cruising the galaxy shopping for equipment, blowing things up, and collecting mechs. It looks though like it’s going to be a serious pain to backfill all the lights/mediums I sold in the early game. In the later parts of the game missions less than 3 skulls seem to be nonexistent. I may have to resort to just buying them as I find parts for sale.


#2434

Anyone else having a clueless APC AI being unable to plot it’s way to the waypoint in the final mission?

My allied APC’s are moving back and forth. It’s been 20 turns of this silly AI failure while I adjust the positions of my mechs. Seems like nothing will work. Anyone have a clue on this can be resolved?


#2435

Have you tried running to the waypoint maybe it’s occupied.


#2436

I had that happen to me during a generated mission and a story mission – both required me to restart them. The patch notes for 1.03 make it sound like this may have been addressed though.


#2437

I don’t know if it’s just me, but the AI seems dumber since I’d been playing with the 1.03 beta and now pushed version. I’ve had a few instances where tanks will just sit there doing nothing until I go shoot it and take it out. A lot of my 4-5 star missions have mechs with low armor, whereas pre 1.03 all the mechs were nearly/always full armor. I’m doing missions around the research/manufacturing Tauran capital area to try and get better gear and some mechs I don’t have so the mission zones haven’t changed.


#2438

Low armor enemies were common at launch too. If the mission says something about them coming from a battle or stuff like that, it’s mostly shown through depleted armor.


#2439

Argh. My second contract went super well, defending a base and getting bonus credits for no damage to the base, and 2/3rd of a Jenner. I click next after salvage and game crash. My only save is the auto-save when the mission started. Not a great first impression there, with me not wanting to replay that damned fight again and HOPE it goes as well the second time. Sigh.


#2440

Hopefully that will be a rare thing for you. In my 80 hours of play so far, I’ve only had to redo 1 mission due to a bug where it got stuck and wouldn’t progress to the next turn in the mission.


#2441

Only real bug I found other than the supposedly now fixed permanent morale status one was a doozy–late game, right before setting off on the final mission, game would not advance the clock for work orders or any other tasks because a financial report event was still in the queue though it was marked done. Had to ditch that campaign and start a new one. Not a big deal, as I kinda wanted to do that anyhow.


#2442

Another pilot bites the dust. Down to killing the last mech in a base defense mission, and the griffin does a death from above onto my hunchback, destroying the head and killing yet another pilot. I think I’ve lost 3 pilots in the last 5 missions now due to the head being destroyed.