Best blobbers and/or 2d RPGs available right now on PC (no roguelikes/lites or puzzlers please!)

Oh, that’s very good to know - I should revisit that. I enjoyed the combat a great deal and thought it looked and played just lovely. Cool game.

It’s one of my favorites of the last few years, and I’m completely in love with the soundtrack.

I want to talk about this one a bit, since I actually played some of it after picking it up for a few bucks in 2018. (According to Steam, I played it for almost twelve hours, which doesn’t seem right for how frustrating it ended up being.)

Moero Chronicle is thoroughly disappointing, but not because of the dungeon-crawling gameplay, which is solid and has cool enough stuff going on that it would be worth continuing to play if not for the nonsense I’m about to describe. It’s thoroughly disappointing because of the reason that NSFW tag is in there: it’s a follow-up to a previous Idea Factory game, Monster Monpiece, which was a card game with an interesting pre-Clash Royale real-time battle system. Monster Monpiece had a truly heinous system for upgrading your cards, and Moero Chronicle kept that system for recruiting new party members and upgrading their abilities: you have to strategically rub the anime girl you’re upgrading. Frankly, it would have been significantly less terrible if these games had an option to disable this garbage mechanic so you could play them normally, but they instead chose to double down on the ultra-pervy design; the third game in the series, Moero Crystal, advertises the option to rub two girls at once.

If rubbing anime girls sounds like a good time, go ahead and try these games, but I have a feeling most people here would be even more disgusted than I was.

I think they’re designed for a touchscreen, so, yeah.

My experience matches that description. By which I mean to say that, considering my own point of view on the experiences provided by both of the games mentioned, I came to the same conclusions as Left_Empty. Or, in other words, he’s right.

I actually thought the card-battling mechanic in Monster Monpiece was pretty interesting, and also it was a game I could never talk to anybody about ever. I kind of wish it had been iterated on in a non-gross game.

I don’t actually know much about the two Moero games, except that Crystal reviewed better than Chronicle. So either the bad parts are less objectionable, or the good parts are better, or they managed to better restrict review copies to their target demo.

I misspoke, MAry Skelter does not allow for adjustment of encounter rates as a setting (there are items that do so). It was some other game I just recently got that does that, apparently.

Another -1 for Xulima. Felt more like an obtuse puzzle than an RPG.

Just bought Conglomerate 451 yesterday (it was on sale, 80% off at Humble, not sure if it still is). Be aware though that it has a roguelike structure, which is a no-no according to the thread title.

Thanks for the heads up.

Regarding Xulima I have to agree too. The extreme linearity of viable encounters you could take on was too much. I think I got about 20h or 25h into the game before I shelved it. One thing that particularly annoyed me is that you had to wait until you had 30 skill points in Herbalism before harvesting plants became worth it.

Yeah, I didn’t play Xulima that long but it indeed felt like a puzzle RPG where you scrub everything on the map and pour XP and gold into upgrades that allow you to repeat the process on the next map. I’ve read some of the tips saying “and naturally at some point you’ll want to kill all the guards in the town for XP and gold” and it raised my brow.

Still, the clay character style was the deal breaker for me. Also those devs later released They Are Billions.

So this thread made me want to replay Might & Magic X: Legacy so I fired it up on Steam. Or tried to. It got to the point of logging into Ubisoft Connect and then told me my CD Key was registered to a different account. So I tried firing up Ubisoft Connect directly from my desktop and it opened up fine and I made a new party and saved as I was just about to start. So earlier today I went to get the game going via Ubisoft Connect and it gave me that crap about the CD Key again.

I’m not looking for technical support because: FUCK UBISOFT. I just uninstalled the game on both Steam and Ubisoft Connect. I wasn’t that interested in playing anyhow.

I haven’t paid much attention to them in recent years but FUCK UBISOFT. They can go to hell.

I hope you’ll give the game another chance, despite this bad experience, because it’s a really good title and well worth playing.

Did this require all the UBI-add-ons when it first came out? I had literally just started it up back then (< 1 hour played) and then got distracted by something shiny and never really got into it. I tried to load it up this morning based on the discussion here and I’m 20 minutes deep into installing a bunch of UBI services that I don’t really want, kicking out random error messages here and there, and seemingly no closer to getting the game started than I was at the start of it. In a world where I couldn’t just let my desktop run through this crap while I work from home on the laptop, I’d have dropped it by now.

In closing, I concur with your FUCK UBISOFT.

Your call, of course. For what it’s worth I expect if you do get in touch with them they’ll fix it promptly, my experience with the tech support has been pretty uniformly positive.

To be fair and update a bit, I got things working eventually and after an hour I can confirm that I do, in fact, like this. I’m not sure it has quite the “magic” of some of the classic M&Ms, but it’s competently done and scratches the appropriate itch. I will now proceed to forget about the entire experience of getting it working, not play another Ubisoft game for five or six years and a new PC, and then go through the entire thing again and expect it to just work when I naively click “play”.

Fired up Labyrinth of Refrain after a year’s hyatus, and while the inventory management is a mess, it sure keeps the job done on the mapping a dungeon front.

And I fired up Etrian Nexus again thanks to this thread lol… and am reminded how it arbitrarily ‘challenges’ you by destroying your party’s health/mana at particular map points. Ugh. :D

Still much more polite a game than Strange Journey on that front, though!

(This is in reference to Might & Magic X: Legacy)

So, based on this I decided to put in a ticket - given that I was not planning on playing anyway, I felt I had nothing to lose. And Lo and Behold, Ubi got back to me within a couple of hours, with a fairly easy fix: delete a certain config file and restart Ubisoft Connect. The game is working fine now.

I just finished the first spider dungeon and the game is humming along. It’s quite good for what it is.

So, thank you @vinraith for having faith when I had none.

I’m glad it worked out for you. I don’t have any affection for them as a company but this really does match my experience - they’ve got pretty good customer support.