Beta patch for Oblivion

Seen on FilePlanet. Here’s a portion of the description:

Bug Fixes


Fixed an issue with falling through collision in Fort Wooden Hand.

Fixed issue with remapping controls in French, German, Italian and Spanish versions.

Fixed issue with crashes on exit.

Fixed issue with some shadows not lining up.

Going to jail while equipped with bound armor or weapons no longer crashes the game.

Fixed issue with bound weapons not dispelling properly after dismounting a horse.

Fixed issue with player shadow being delayed after fast travel.

Fixed infinite gold issue on some dead NPCs.

Fixed issue with disease resistences that made it impossible to contract vampirism under certain circumstances.

Fixed an issue where occasionally skills would not increase properly after you received an increase in a way other than skill uses like as a quest reward.

Fixed issue where spells, powers and lesser powers were being improperly resisted when the player cast them on themselves.

Fixed an issue where creatures and NPCs would not go into combat properly after being hit by a projectile.

Fixed an issue with duplicating items and unequiping the bow.

Fixed an exploit that allowed you to sell equipped items to a vendor more than once while on a horse.

Fixed an issue with items reappearing in dead bodies after saving and reloading.

Fixed crash when NPC with active light spell on them unloaded from memory.

New Ultra Low Quality graphic setting available under Launcher options with improved support for low end FX cards (5700 and lower). To use this setting, go to the Launcher, select Options and click Reset to Defaults to allow the auto detect to check your system.

Implemented SLI-mode optimizations on Nvidia cards, and Crossfire optimizations for ATI cards.

Quest Fixes


If you are permanently expelled from Mages Guild, you can now go back into the Mages Guild buildings.

In The Siren’s Deception, the player can no longer get locked outside Gweden farmhouse if they exit too quickly.

In the Light the Dragonfires quest, fixed an issue where player controls get locked if player accidentally hits Ocato during the final battle in the Imperial Palace.

In the Confront the King quest, fixed an issue where Mannimarco would occasionally stop fighting the player while the player’s controls are locked.

In Corruption and Conscience, fixed an issue if player got to Llevana’s house earlier than expected and she would initiate trespass behavior rather than move the quest forward.

In Theranis’ Mistake, it is no longer possible to get multiple copies of Ahdarji’s ring. Also, fixed an issue with player receiving Blood Price topic too early in the quest.

In the Leyawiin Recommendation quest, it is no longer possible to bypass Kalthar in Fort Blueblood.

In Revenge Served Cold, Corrick will now recognize when player had the jade amulet in their inventory if No Stone Unturned quest had been previously completed.

In Infiltration, player can no longer kill Blackwood Company members and stop progress in Fighter’s Guild.

In Dark Brotherhood, if you kill fellow members and get kicked out of the guild, you can no longer continue to progress in the questline until you redeem yourself and get back in.

In The Master’s Son, the player now properly receives their reward when completing the quest.

In Caught in the Hunt, fixed an issue where NPCs would not go into combat properly.

In the Cheydinhal Recommendation quest, fixed an issue where Vidkun’s body would disappear if you left the well.

Getting disqualified from the first Arena match no longer blocks you from further matches.

In Till Death Do They Part, the Count no longer rewards player with gold more than once. Fixed an issue with not receiving the Vampire Ashes topic if the player picked up vampire ashes before getting the quest. Fixed issue where Bloodgrass topic was not added if player finished the Main Quest before starting quest. Hal-Liurz will now follow player properly when asked about the cure.

In Mystery and Harlun’s Watch, the dead body you are supposed to find will no longer disappear from Swampy Cave if you cleared out the dungeon before starting the quest.

In Blood of the Daedra, Martin will now recognize Spellbreaker as a Daedric artifact.

In When the Vow Breaks, fixed an issue where a second instance of Rockshatter would reappear back on Bjalfi’s dead corpse after saving and reloading.

In Paranoia, game no longer crashes when Bernadette Peneles exits the city while you are following her.

Plugin Fixes


Fixed issue with saving your game while an actor is in a new interior cell created in a plugin, and re-loading the save game without the plugin.

Fixed issue with loading previous saves with plugin that contains new base objects that are containers, NPCs and creatures.

Fixed issue with linked pathpoints scripted to switch on/off that are modified by a plugin.

NPC’s companions no longer disappear when they fast travel with player to an exterior cell that is modified by a plugin.

New scripted spell effects created in a plugin now work properly.

Is this the patch that will give me 30+ FPS with all options on without having to upgrade? :}

Nice to see the patch notes HAVE SPOILERS. Cruel Bethesda! Cruel!

Nice. I’ll download it just for this. Thanks for the heads up. :)

That patch is already out.

http://www.oldblivion.com/

How does it look when youre running it with the Oldblivion patch?

I’m going to have to try this out…
I was playing as usual and after a normal Load I find that my character moves at %.00025 movement speed. It takes my character 10 minutes to walk across a small courtyard. He can’t even walk up stairs, I have to jump over each one it’s that slow. I reloaded saves from well before this point and it seems to be set in the game somehow… pretty much scraps the character. I should do a FRAPs capture, as the running animation takes about 3 minutes to complete a single cycle. I had vampirism and thought it was some strange affliction of not feeding, and I wasted 20 minutes finding someone who was asleep. No dice there.

Are all of those quest bugs in the 360 version? I can’t see how that particular part of the code would fork between versions. And if they’re in the game, yikes.

I believe they are patching the 360 version.

I ran into that as well, and it turned out to be interference from the gamepad I have connected. The analog stick was slightly off-center, and Oblivion was interpreting that as a really slow movement request, and then modulated any keyboard inputs to that same slow speed.

I’m not sure if there’s a permanent way to disable gamepad input, but fiddling with the stick until it no longer interfered got rid of the problem temporarily.

I had a shoe on my gamepad!

http://www.oldblivion.com/screenshots.php

bUse Joystick=0 in Oblivion.ini solves this issue for people with joysticks. It may work with gamepads too. Not sure.

Hah, sure enough. Thank you kindly, good sir. I was certainly stumped!

Glad I didn’t wait for the patch. They didn’t fix or add anything besides a number of smallish bugs that I never encountered. No rebalancing, no performance improvements for my card, and no proper Gamepad support (those tips have been in the forum forever).

I am looking forward to the “no more crashing on exit” issue being resolved.

Hey, thanks for that! I wasn’t even able to start the game before due to my decrepit video card, but with Oldblivion it started right up. Some of the textures are fugly, but the damn thing runs reasonably well, so I no longer feel like I wasted $50.

Heh, I agree.

I expected something more.

Bah, zero framerate improvements, nor they fixed the mouse lag problem and that bug with the drivers.

Nor the stutters with the sounds being cut or not playing at all during combat.

Plus no crack, so I have once again to put in the DVD.

And the distant LOD textures mod doesn’t work anymore after the patch.

I wish I could rollback…

I’d check this this out: http://www.tessource.net/files/file.php?id=3736

You just run it, point it at your Data folder for Oblivion, and it will either add or create an appropriate Archiveinvalidation.txt file for you which instructs the game to ignore whichever default textures you have replaced. Worked like a charm for me to get my LOD textures back up and pretty again.

GCW has a fixed image you can mount in Daemon Tools if you are like me and hate handling discs all the time(I have a 4 year old that is around my pc quite a bit). Just be aware that even though the filesize is tiny when it’s compressed, once you unrar it windows thinks it’s full sized(the image that is). Make sure you have the HD space to waste if you intend on using it.

Oh on a insignificant note; the beta patch seems to have un-fucked self shadows for me. They now display properly on characters and look quite nice, so i’ve turned them back on.