Beta patch for Oblivion

Hear you, hear you. :-( I have been delaying playing Oblivion up until now after reading many reviews and first impressions complaining about terribly implemented scaling and balance in the game. So I have been waiting for the official patch, despite my strong suspicion that Bethesda wouldn’t really do anything for the game balance. (their lame horse armor update was the “writings on the wall” for me)

Well, at least some of the more complex and comprehensive balancing mods will reach its final “mature” stage soon. (or perhaps have reached it already?) My hope is that they will fix broken item/mod scaling balance, at least to some degree. I know that in Morrowind the combination of such mods made the game 10 times more interesting and exciting for me.

So are there any comments on the current state of these scaling/balancing mods for Oblivion from the Q3 forumers who have used them?

  • Still waiting on the “don’t crash on shutdown” fix

  • Need a crack for the new exe? Buy GameJackal. Duh.

I thought the beta patch was supposed to fix the crashes on exit also? I know I used to get the crashes on exit occasionally, but since the patch i’ve only gotten it one time. I even started it a few dozen times, loaded up a save and exited shortly afterward without error messages. Seems to have improved that on my end in any case.

I support this idea. Well worth it.

And…there are balance issues? I mean, I’ve read about them here and at other forums, but I haven’t encountered any. Of course, I’m a veteran of PnP RPGs, where the content is levelled as a part of its design, so I’ve never seen a problem with how Oblivion works as a game.

However, I am working on a plugin to see if I can resolve issues Charles has with the game, as a kind of personal challenge/hobby. All I can say is the results aren’t pretty at the moment. Bandits wearing a mishmash of mostly leather and fur but sporting one piece of glass armor, as an example, looks pretty tacky and unfashionable.

I think that guy’s giant argument about how the influx of Daedric Armor would flood the market perfectly explain’s the bandits running around in full glass armor. Why isn’t the price decreasing? Simple! Inflation.

Sean: Which rarity mod are you using? I was using seth’s and switched to Jarols, which seems quite a bit better about producing non-absurd mixes of armor.

Worm, can link to the rarity mod you’re using? That’s something I’ve been waiting for - before starting my game “for real”.

So whywould people not play with the beta patch if it fixes a whole bunch of quest issues?

So GameJackal actually works? Even after they ‘fixed x64’ it didn’t work on my x64 box. Heh.

I’m back on XP probably til Vista is out, so heh. I could try it again.

Can’t find it. There’s the one by Seth and one by PlasticFoamMan, which has rarity with mobs. It seems like similar ideas are getting combined.

I believe Oscuro’s mod addresses a bunch of the balance and rarity issues.

It’s one I’m putting together myself. All the other mods I’ve seen use seemingly arbitrary rules to determine what should go where. What I do is change the levelled lists by changing the probability of items appearing, regardless of level, but I don’t add or delete the items that are in those levelled lists. I determine the probabilty of an item based on what level they are originally supposed to appear. 1st level items are the most common. 30th level items are the rarest.

I should probably get the mod which changes the color of glass armor from godawful green to amazing obsidian. Perhaps NPCs having mixed armor types won’t look so crappy then. A side effect of the plugin I’m working on is money is REALLY hard to come by but that’s sort of cool. My character is level 26th and can’t afford to purchase, let alone decorate, all the houses yet. Gives me a reason to spelunk. :)

I’ve done quite a few of the quests listed in that list (on the 360 version), but I didn’t run across those bugs. So there must be some special circumstances that cause the bugs beyond what’s mentioned in the bug list.

On the other hand, the two biggest bugs I have encountered in the 360 version are not listed there. One of them was in the Dark Brotherhood questline, and we fixed it by loading an earlier save. And the other one was in the Bruma recommendation for the Mage’s Guild. Of all my friends, only I got that bug, and we have no idea what I did differently. And the bug didn’t go away for me by reloading an older save either. I just had to find an alternate way to finish that quest. (Thankfully, that particular quest had two methods).

I suspect all the bugs are like that: caused by special circumstances that are really hard to replicate. The kind of bugs I see in console games all the time. On the PSX, N64, Dreamcast, PS2, Xbox, etc.

Thankfully, now there’s a mechanism for them to be able to fix these kinds of obscure bugs, unlike older consoles, where you were just shit out of luck. (Well, except for certain X-box games, obviously, once Live-enabled games started coming out).

I wonder how they’ll handle patches for the non-hard drive 360.

Hell, how do they handle patches at all? Do they suddenly run a patched executable from the hard drive instead of the one on the DVD? Most PC patches hit a lot of different files.

I just crashed quitting the game …

I’m pretty sure that’s exactly what they do. I imagine all games have to be architected such that they can be patched somehow on 360, otherwise you simply can’t patch it. I think that’s why some original Xbox games got updates (Halo 2) and others did not.

I crash every time I quit the game. I’m just completely used to it now.

I managed to break the scripting of the Fort Blueblood mage guild entry quest pretty well. You’re supposed to have to defeat an NPC to get a key to leave the room. Well, I’d picked his pocket and gotten the key like an hour beforehand. So, when he showed up in the room and attacked me, I thought “Hey, I’ve got the quest item… SEE YA!” and ran out of the room. Then I find that the NPC you deliver the item to doesn’t give you the option to hand over the item unless the other guy is DEAD. Ugh. So I go back to the dungeon, and I can’t find him anywhere.

Why they wouldn’t trigger the conversation option based on my posession of the item is amazingly weird to me. But it’s based on “is X dead?” I ended up reading forums until someone gave a console code to set the trigger state right.

Have you tried quitting with:

instead of exiting normally? (open consoel, type qqq, then hit enter)

I never crash that way, seems 50/50 if using the menu.

Final is out. Notes, Patch.

Kinda afraid to install it with all these pluggins I have running. I take it you have to restore the game to its vanilla state before applying the patch?

I don’t think it really matters honestly. mods and such are only loaded when you start a game so I don’t see that it would conflict.

As a bonus, a way to make your Arena fan commit suicide. Search for “Emo Fan”.