BitTorrent - Recource hog?

I’ve noticed that BT uses 90% - 99% of the cpu time. Why?
What’s in it that needs so much processing power?
The version I’m using is Shadow’s experimental. I tried Bram Cohen’s own original version, but that also used up all my free RAM so I ditched it (and made me think badly about Steam).
Does anybody know a better BT version?

I really like G3 Torrent.

That’s strange.

The only one that I know of that really takes a lot of resources is the Java-based Azureus.

G3’s pretty nice.

It gets like this after BT is working for some time, and everything locks up. I don’t know much about operating systems, but isn’t Windows supposed to stop applications from taking over the cpu?

Looks like there’s some kind of problem with that application. Switch to another bittorrent app. I like Another Bittorrent Client (ABC) myself. It’s compact, doesn’t use many system resources, and it’s simple.

Another vote for ABC. I really like the ability to restart torrents after a reboot by simply starting the ABC window back up. I also like the little “keep uploading until XX% ratio reached” feature as well.

Yeah, some versions of the old experimental BT client were buggy.

You should be using BitTornado instead. That’s what the experimental client has morphed into. It has everything you liked about the old client, but uses less CPU and has allocates disk space faster.

I really like Azureus for a bit torrent app.

So I installed ABC and it has the same problem. It’s not so annoying because I just leave it working while I’m away, but I’m still curious as to why it happens at all.

yoav, what kind of computer do you have? how fast is the cpu, how much ram do you have?

Maybe your hard drive isn’t running in DMA mode.

I had the same problem with my setup. It might be caused by your router not being able to support the default number of connections that BitTorrent uses.

By default it uses 60+ connections, I think. Try turning the number of connections in use to 20 or 30 and see if it still happens.

My specs:
PIII 1000
(I don’t know if this is relevant: 20GB HD)

How do I find out what mode the HD is running?

Right click on My computer, click over the hardware tab and click device manager.

Expand ‘IDE Controllers’ and right click to get properties.

under advanced settings current transfer mode should be "ultra dma mode’.

Not having this enabled means the computer uses tons of cpu cycles every time it writes/reads from the disk.

There are 3 items under IDE controllers:

  1. intel ‘somthing’ bus master ide controller - no advanced tab here.

  2. primary IDE channel -
    device 0 current transfer mode - ultra dma mode5
    device 1 current transfer mode - ultra dma mode2

  3. secondary IDE channel -
    device 0 current transfer mode - ultra dma mode4
    device 1 current transfer mode - multi-word dma mode2

That seems to do the trick. ABC now content using about 10% of the CPU time which is OK with me. Thanks.

I vote for Azureus as well. It’s the only UPNP supporting application that works properly with my firewall (ie it doesn’t rely on Windows API).

I have an older ‘experimental’ version that allows for setting the upload rate and # of clients to upload to. The wierd thing is that it does nothing to the download rate. It’s not unusual for me to set it to the weakest dial up settings, using maybe 2k upstream while pulling 200+k downstream. I realize that goes against the point of bit-torrent, but whatever works.

It doesn’t matter what your upstream or downstream is at. What’s important is that you eventually upload as much as you download. I’ll have torrents at 5k upstream, but I’ll just leave them open for a couple days until the ratio hits 1:1.

But, if you’re saying that you download 350MB of stuff and close the window having only uploaded about 2MB back to other peers…

[puts a flaming bag of crap outside your door and knocks]

That’s one thing I like about the ABC client, in that you can configure it to automatically continue sharing a torrent until you’ve uploaded a certain ratio percentages, which I usually leave to 125%.