Can't forward a port in Windows Vista :(

So I’m trying to do some particular port forwarding stuff, and for some reason, I’m getting hung up with something that I suspect is Vista related.

Let’s say I want to forward port 3074. I set up my modem to let it through to the LAN. Easy enough. Then I go to my router, a recently bought Linksys. I tell it to forward the port to an IP address that happens to be a computer with WinXP. Again, easy enough. I run a routine called PF PortChecker on that computer. It confirms that port 3074 is open. OPEN even!

But now I change the setting on my router to forward the port to an IP address for a computer with Windows Vista. I run PF Port Checker on that computer and it shows the port as CLOSED.

Is there some step I’m missing particular to Vista? I’ve even assigned the Vista computer an IP address outside the router’s DHCP server range after reading that particular recommendation on some randomly Googled message board. Talk about grasping at straws.

For what it’s worth, under the Windows Security Center, I’ve got the firewall set to OFF. Under Internet Properties, the security level is set to Medium-high (the default). It seems to me there’s some weird Vista related reason I can’t get the port open. Anyone have any idea or know how I might further troubleshoot this PITA?


There’s no difference to Vista and XP in this regard if the Firewall is off. For all win32, there’s no restriction on listening on ports.

Some psychic debugging questions / hints:
Are you only forwarding UDP and does PF PortChecker only test TCP sockets?
What happens if you run the helper app as an Administrator?
Do other ports work?

You have both computers on the same LAN? If so, try opening a connection to port 3074 from the XP machine to the Vista machine. If that doesn’t work, then the problem is not the port forwarding, but rather that Vista is still blocking the port somehow. If it does work, however, then it’s more likely to be something odd on your router.

Worth doing it the other way around, too (vista connecting to xp), as a trial run to get a baseline.

By any chance are you trying to host some windows live game?

This has more to do with halo 2 (you aren’t actually playing halo 2 on pc are you?) and says something about if port 3074 is busy it tries the next available port in increments of 12:
So a possibly theory is 3074 isn’t the actual port getting accessed but some other port? Shrug

I have no idea if this has anything to do with your situation. The most obvious would be the built in windows firewall which you’ve already disabled. Yea, I’m at a loss.

Do a port-trigger with a range, you’ll have better luck. Or better yet, use a UPnP aware application. It’ll do the legwork for you! Azureus works for this, I think also uTorrent. With games, you’ll probably have to either use a port range forward or range trigger.

Have you set the Vista machine to a particular IP in Vista or on the router? It should be set on the router, under static leases or something like that.

Did you reset your router after changing the port forwarding settings?

Is the program running on the Vista box that is using the port in question? If it’s not then the system may not be listening on that port while you are doing the test with the router. Here’s a quick guide on how to find out what ports your system is listening on.