Can't open html files with firefox anymore

i have firefox

.html files used to have the firefox icon, now they have the notepad icon. when i try to do “right-click > open with…” it shows some programs. when i browse for firefox.exe and choose it, nothing happens: it doesn’t appear in the list of open with programs, and it remains listed as a txt file type.


possible foul up causes:

i had tried to install firefox beta 3. after trying the lifehacker trick so my extensions would work, hitting enter in the location bar did nothing and some other extensions i wanted still didn’t work so i uninstalled.

while looking at the list of install/uninstall programs, i also uninstalled a firefox version 1.5 i still had.

a few hours later later i noticed the html files stopped behaving like they belonged to firefox.

going to file types under folder options doesn’t help: browsing for the program to open a file goes to the same open with… dialog that can’t select firefox.exe.

what am i missing here?

Uninstall all versions of Firefox. Use Ccleaner to clean your registry. Reboot. Reinstall a non beta version of FF and see if it works.

reinstalling firefox worked: thanks!


Either that or go to the shell and register .html to firefox.exe and pass in %1. That’s what it does on install.