Can't reach AVS Forums on my PC, but can on my phone

I’m trying to look at something on the AVS Forums (audio visual stuff) at and I get a DNS resolution Error 1001. It says the site is on the Cloudflare network and it can’t resolve the DNS.

I use one of those sites to check if a site is down, and it says it is up. I use my iPhone, no problem getting in. I know they updated our computers here at work last night, is there something I can try to resolve this?

Clear browser cache ? Is it just a certain browser or all the ones you tried?

If its a real dns issue:

  1. Click on start menu search and type ‘command’.
  2. From search results right click on Command Prompt (make sure you’re running it as administrator).
  3. Type ipconfig /flushdns and hit enter.
  4. Reboot. :)

Change your DNS and retry (change it to the one on the phone)

Clearing the browser cache worked for some reason. Thanks

They made some change on their end, and your browser was still trying to use the cached (and now useless) data.