Can't start Steam in Offline Mode!?

I’m out at my moms and for reasons not worth expaining I cannot connect my laptop to the Internet. No problem, I’ll just play that copy of Dungeons of Dredmor I bought last night.

Now, for some reason I cannot open Steam in offline mode. I have tried clicking the Start in Offlne Mode to no effect. I keep getting a bong and some message about “could not connect to Steam network”.

Well, no shit Steam, I know I’m not connected online, that’s why I selected start in offline mode.

Is there anyway to fix this, or am I in for a long, dull night?

I think you have to run offline mode once while online to authenticate everything in advance, or something, then afterwards you can run those games offline. It’s not a good system. How are you posting this message?

You are in for a long dull night.

I’ve seen Steam start in offline mode, I remember it giving the option to do so, even if you didn’t “properly” restart in offline mode before going offline.

Yeah, I’ve run it in offline mode before on this machine a few weeks back, so it shouldn’t be an authentication issue. Boggles the mind.

I’m posting from my mom’s machine, but she is on some weird wireless sevice that has Client installed that I can’t use on my machine.

sigh now I wish I had brought my PSP and my book. Damn Steam!

I think you can still play Dungeons of Dredmor without steam, go to the game folder inside steam and there should be an .exe in there you can use.

I can’t seem to get to any Steam files so I don’t think running the .exe is an option. And people wonder why PC gaming is dying…crap like this.

What do you mean you cant get to any steam files? the game isnt installed?

Sucess! Thanks for the end around MrCofee, took a bit of digging but I found the menu you posted (it’s under a few different subheadings on my laptop). Once again smarter heads than mine prevail.

No problem!

Also make sure you have - remember password checked. It is a bug but you need to do that now.

Ah yes - the PC gaming is d0med mantra.
Hey, we are all dying. I’ve been dying for 30+ years. Thanks for the lulz.

Aha, and it’s being worked on is it?

I just restarted in Offline mode no problem. It does fuck up if it wants to update at the time, though.

The problem is when you want to START steam when you dont have internet and its not set to offline mode, it will ask you if you want to start in offline mode but then give you an error sometimes.

Yeah, it’s been annoying me, too, lately. My connection is a bit flaky, and when it goes down, it does so without warning, which means I can’t use Steam. I hope this is a bug, and that it will be resolved soon.

Umm…where do I check that? I’ve looked but I haven’t found anything.

I encounterd the same login issue last night out at my mom’s and it is more than a little annoying. A big reason I want games on this silly PC thing is so I can play them out there. It doesn’t do me much good if I can’t log in.

I can end around for DoD, but I wanted to play some Torchlight…and no dice. I gotta say it’s bad for business (at least from me) since I am no longer sure if it’s worth buying Steam games since I can’t even use em when I want them most. :(

The password check is when you log in, but it wont matter if you dont have internet in the first place.

Handy that. I think mine just logs in automatically every time I start up my computer.

[li]Added Steam Trade (see the Steam Trading Beta FAQ)
[/li][li]Added inventory view on Steam Community profiles, to see your TF2 items
[/li][li]Added drag-drop of items from your inventory into chat
[/li][li]Added bucketing of friends in the friends list – right-click on a friend as select ‘Tag as…’ to organize them into categories.
[/li][li]Added Brazilian-Portuguese and Bulgarian language support
[/li][li]Added a much improved dialog for when a game is being converted to use the updated content system
[/li][li]Fixed a case where Steam Guard would unnecessarily re-ask for activation in the Steam Client.
[/li][li]Fixed offline mode not working if there was no remembered password.

Gosh I hope this solves my issue. It’s such a bummer to sit down to play and then just get nothing but an error message.