Civilization 4 - Complete issue

Can someone give me a hand here. I’ve just bought the Civilization 4 Complete bundle (Civ 4 and both expansion packs) and I’m having a problem.

Whenever I try to execute any of the executables nothing happens. I’ve tried from the auto run screen, from the icons on the desktop and from the .exe themselves.

Does anyone have any idea what is causing this?

I found mention of this problem online and the person was referred to this thread, so maybe you’ll find an answer in there. Another suggestion I found was to be sure you are installing the game while logged in as admin, or you could also try making a new user account and installing it through that.

I’ve no experience with this issue myself, my suggestions are just based on a bit of googling. I hope some of it helps.

Thanks for the link. It wasn’t that though.

I asked myself : What single thing related to gaming causes most of the non game bug related headaches?

If you guessed copy protection you would be correct. I found that if I ran Civ 4 without admin rights it would give me an error message telling me that I needed to run the game with admin rights. Clearly this meant that there was some dodgy copy protection bullshit going on. I then saw the diag.exe file on the CD which is a securerom file. Ah, ha. There we go. Treating paying customers like criminal bullshittery ahoy.

For some reason I thought to check the device manager and view the zuper zekrit drivers that are installed and the SecDrv driver was disabled for some reason. Since I’ve never disabled it, I have no fucking clue why it would be disabled. Fortunately enabling the driver again solved the issue.

Could someone please remind me why PC gaming is dying again?

It’s all the pirate’s fault! No way that ham-handed copy protection or DRM could possibly ruin PC gaming. Any more.

Copy protection isn’t the issue. All three of the consoles have significant copy protection schemes. The problem is the inconsistencies between all of the PC’s out there. On a console a developer/tester can count on the hardware and software that will be in place. On the PC its a crap shoot.

I avoid games like Bioshock on PC because of their stupid copy protection schemes. And I avoid games with Securom and Starforce too. And, as I like to repeat often: I used to spend shitloads of money on PC games. Now, I just get my Rock Band DLC and buy used console games… PC gaming ain’t quite dead to me, but it’s seeing the light at the end of the tunnel…

That’s partly the issue but copy protection is also an issue. Sure the consoles have copy protection but it never, ever interferes with the game running properly.

I can think of SEVERAL instances just in my personal experience where copy protection screwed me on a game I had bought legally from a big box store. See the “Act of War” thread here for an example.

Yeah, you’re right. Its definitly inelegant on the PC.

Thanks for making it clear I shouldn’t buy this.

Yeah, it’s kinda unfortunate. Firaxis makes some fantastic games, but there QA is damn near shit. I don’t think there’s been a Firaxis game that I haven’t had multiple problems with. Since it hasn’t gotten better over the years I can only assume that they just don’t care about QA.

Except that in this case I don’t think it was Firaxis’ fault. Now that it is up and running I haven’t had any problems with the game itself.

It’s not as if this copy protection would prevent me from pirating the game if I’d wanted to. It’s just frustrated someone who’s bought an original copy.

It also sucks that if I hadn’t applied Tim Schaferesque logic to the problem and hadn’t gotten the game running there would be no way for me to return it.

So in others words this thread is nothing but a veiled console-fanboy whine?

I don’t know how this stupid qt3 meme of bitching and moaning about PCs started but please, SHUT THE FUCK UP!

Uh, no. We have valid complaints about how our hobby is being run into the ground. So bite a Wii!

Except the complaints are nothing but whines, and there is already multiple threads for them, full of go nowhere hyperbole. This argument hasn’t evolved in years. I’m ticked that I actually though I might be of help to someone when I clicked on the thread only to find out to was a bullshit trick to bitch and cry about Starfo^H^H^H^H^HafeDisk and how PC gaming is d0med.

Fuck off. I had an authentic problem for a while and really wanted someone to give me a hand to get my new coffee coaster to work. Fortunately I found the solution shortly afterwards and thought I’d post my solution in case anyone else somehow found themselves with this fucked up problem. And yes, it’s fucked up. The moment you start forcing paying customers to deal with this bullshit, you know you’re on the wrong track.

As for it being a console fanboi whine, what is wrong with you? I don’t even have a fucking console and nor do I plan to buy one.

I’m in the same boat, now that I have a 360 I can buy alot of my cross platform games on it without worrying about CP.

Right now the only games I’m going to buy for the pc are indie titles and games that don’t have CP on them.

That’s the awesome side of piracy. Copy protection is becoming so intrusive that people feel justified downloading games.

Well back to play Galciv 1-2 and Sins which I paid for. I’ve tossed Bioshock aside until I can figure out why it only launches half the time and opens my DVD drive at random intervals.

I don’t pirate games, but I can easily pass on a problematic Civ upgrade.

Complete isn’t an upgrade, it’s a combo pack. It might also break mods, so, uh, watch out.