Civilization VI


#2847

I haven’t got around to Civ6 yet (too pricey for the problems it’s alleged to have), but this is one of their more inspired civ choices. It looked like the series was moving away from its Eurocentrism with V, but VI and its early DLCs regressed on that point. Nubia helps correct that, if only a little. I would love to see a Caribbean or Circumpolar civ next.


#2848

Odd litle bug in the new patch, sounds like.


#2849

So is this latest patch as game breaking as Steam whiners would have you believe? Lots of technical glitchiness and leaders asking about nukes even in the bronze age?


#2850

Civ V was it for me, I guess. I haven’t purchased any of the DLC for VI, which is nuts because I enthusiastically bought every expansion and DLC for the past games on day 1. Unless I see some drastic changes in VII, I won’t be purchasing it at all.


#2851

No, but to be fair I’ve only had time to dabble so perhaps The Great Bugginess just has yet to descend on me. .


#2852

The only thing that really matters to me at this point is if the Civ AI is drastically improved or not. You can have the most amazing game mechanics, but if there is little to no challenge in winning, then the game will not be fun.


#2853

No, no. Nubian is the largest ship class in Stars!


#2854

Is there something odd that I’m unaware of happening here. I decided to jump back into Civ6 for a game and set up a new one using advanced options (huge, island plates, prince, starting in the ancient era, random leaders). Settings are basically what I’ve always chosen. When the map loads, my civ never appears, no land/water (just the fow), the turn button is flashing please wait, and the turns are advancing on their own without any input from me. I’ve tried to start the game three different times and the same thing happens.

Anyone have this happen and know what’s up or how to fix it?


#2855

That’s definitely not working as intended. I’d verify integrity and disable any mods you have (if you’ve been playing with any).


#2856

Yep, no mods. I verified the files and they were all ok.


#2857

Certainly weird. Maybe go for a reinstall.


#2858

Just decided to redo the settings for the game again and was able to get it to work, even though they were the same settings. Just a temp glitch in the setup, I guess.


#2859

Been testing out the DLC and patch.

Nubians are fun and interesting. Production bonus is probably the best kind of bonus in this game, and although this is limited to districts, it is totally worthwhile. And since archery units are so central to the game, that bonus is also good. It’s fun having a three move archer in ancient times.

Playing at King level, I would say that you face more resistance than in the past. Some small portion of that is in tactical upgrades – I did have an opponent come and take my city in the early game, with unprecedented competence. But the game is much too complicated for AI to generally compete in the military game. As has been the case, anyone looking for a military-focused game that presents a real challenge, well, I wouldn’t be looking at Civ VI. But as a builder-type player, I am continuing to have fun.

However… I am not all that pleased with the direction of the latest patch. It looks to me like they have upped the level of resistance largely by doling out positive circumstances in a more calculating and stingy manner.

I don’t blame them, they are getting all kinds of criticisms for the game being too easy. But personally, this is what turned me off to Civ V. It always seemed to me that some hidden algorithm worked overtime in map creation to see to it that you were given precisely the correct amount of everything. Initially in VI, map luck varied greatly, which made exploration fun. Post-patch, far less so. When it comes to fortunate facts about your map situation, you are on a very strict allowance, and you are not going to find much variance, at least not upwards. (Unless you play the central seas map, and that strikes me as just broken)


#2860

Civ VI has some oddness with the latest patch. In my current game, Poland and I have been friends since we met, without a single negative diplomatic issue. Five military unit of hers started walking through my territory and I thought they were just on their way somewhere else until they started razing my farmland. I quickly took them all out with city bombardment and my own units but we were never at war, and that didn’t start a war. I’m actually at war with no other civ (there are 12 of us in this game, and 18 city states on a huge map). Every time a unit of hers comes into range of one of mine, the game acts like we are enemies and offers attack options, which I can do…while we are still friends!

I see they still have issues with civs making offers that they themselves don’t like, too, only to have me make it better by clicking the button…to offer the same thing and have it accepted (this happened with Poland, who I’m in the non-war with).

I feel that the game’s gone wonky on me since the latest patch.


#2861

You may have already thought of this but… I had trouble until I removed all mods. Then it worked fine for me.


#2862

No mods. Haven’t ever installed any. Just the game and DLC as they came.


#2863

That isn’t any oddness with the latest patch. That is bog standard Civ VI AI.


#2864

Wait, what? Are you poking fun at the AI or are you legit saying that being allowed to destroy units of another civ without being at war is normal? That’s not behaviour I’ve ever seen.


#2865

Oh, sorry. I assumed it went to war and that you were not at peace. I missed that par, about them not declaring war… The normal behavior is to move a bunch of military units into your area while you are ‘friends’ and then declare war.


#2866

I tried a new game after the patch and I cant seem to build any districts or wonders, is that a known bug?