Clone hard drive


#1

I am replacing my 120GB SSD with a 500GB SSD. Is there a tool I can use to clone the former to the latter without much fuss? It is/will be my system drive with Windows installed on it. Ideally I would reinstall the OS and all my programs, but I simply don’t have the time right now.


#2

Very easy - check out my post from a while ago:


#3

Is it possible without using the USB adapter?


#4

Probably. The NUC box is probably short on spare SATA connectors.

I will say that an external powered USB SATA tool comes in really handy a lot of the time. I think mine is from anker or belkin. And pretty cheap.


#6

Wanted to chime in on what @LMN8R said regarding an adapter or the like (I’ve got a similar thing though it’s an enclosure with a power switch on it, but it still is a drive connector hanging off a USB cable). You don’t use it often, but when you do need to use it, it’s a great help.


#7

I thought there were tools that allowed you to… boot off the 120 GB original, install the tool on the windows running on it, and clone it while it’s the live system.

Then just shutdown, remove the 120 GB and boot off the 500 GB new copy.


#8

Timely thread! I’m trying to upgrade the 512GB SSD in my new laptop to a 2TB 970 EVO, and I’m having trouble.

First I thought I’d just use an external enclosure and the Samsung Data Migration tool, but apparently it can’t see through the enclosure to the drive, so it doesn’t recognise it as a Samsung drive and refuses to work.

Next, I figure I’ll clone the drive using Macrium Reflect, but I get an error. Specifically, error 8, Unable to match partition. Finally I try imaging the drive to an external HDD, and restoring from the image to the new SSD in the enclosure. Same error, though it does seem to be creating partitions each time I try it. Do I need to recreate the partition structure first?

Googling for solutions I’ve seen a suggestion to create a rescue disk and recover from the image that way, but I don’t see why that wouldn’t run into the same error.

Pre-restore setup:

Error:

Any thoughts?


#9

I ended up trying a USB adapter and Samsung’s Data Migration Tool, but it took forever to detect the drive, and then took forever to do the actual transfer. I mean, it took more than 15 minutes to transfer 450 megabytes. (I tried switching to a USB 3 socket, but I have been having problems with the latter that I haven’t quite worked out yet. Like, plugging anything into the empty USB 3 socket causes the neighboring USB 2 wireless M/KB adapter to stop working.)

So I plugged the drive into the motherboard directly, and used a free tool called MiniTool Partition Wizard instead. It copied the partitions okay, but the new drive would not boot. So I booted into Ubuntu, but Gparted reported the drive as working fine and bootable.

So I tried using a Windows 7 recovery disk to fix the MBR, but it would not detect my USB mouse and keyboard. So I had to dig out a PS2 keyboard and try again, and I finally got it to work.

I considered using my old SSD for storing backups, but apparently you can’t leave an SSD sitting on a shelf for a long time or you will get lots of bit rot.

Basically I wasted most of an evening.

Also, my case was caked inside with dust. Got most of that cleaned out with a Swiffer. (I hope that’s safe.).