Connection Drops on Desktop Once an Hour, Every Hour

So, I have several devices (two phones, a laptop, and a desktop) on my home wifi network; it’s been the same since late last year when I switched from a 10MB connection to a 30MB and got a new modem. No work done or software installed on the desktop in the last week or two with the sole exception of a Flash update.

Every hour, at 33.5 minutes past the hour, I lose connection on the desktop for just long enough for Pidgin to have to reconnect to both my Gmail and AIM accounts that are signed in. It’s rarely long enough to be noticeable in my browsers, although it can sometimes kill a video stream from twitch or netflix.

It started about 1.5-2 days ago and has been consistent–to within a few seconds–ever since. As I said, aside from that Flash update recently, there have been no changes to this PC or the network. The other devices on the network (phones and laptop) do not experience the disconnects.


I am also seeing the following error at the listed times (33.5 mins past the hour) in event viewer:

The Peer Name Resolution Protocol cloud did not start because the creation of the default identity failed with error code: 0x80630801.

Googling leads me to believe that following these steps: will fix it. We’ll see in 37 minutes!

Nope, no luck, still dropping every hour on the hour. There’s also a bug in the error log stating that I’m not getting a response from my DHCP at 3 mins past the hour (30 mins before the drop), and then told that I don’t get a response from some DNS server I’ve never heard of in time with the drops (33 mins past the hour).

Any ideas at all?

Have you tried extending the lease time and hard-coding the DNS on the desktop? I wonder if the PNRP error is following on from the issue rather than causing it. Just shooting the dark, though.

Edit: with that comment about the DNS, Google notes in a number of places that this could be the result of malware/trojans trying to dial home. I would treat this machine as compromised until you at least ran Malwarebytes, MS Defender, and outside AV software against it.

Ended up tinkering in the router settings and found that at some point (pushed update from provider? power outage caused system reset? I got drunk one night and did it?), the DHCP lease had been set to 1 hour. Even though I had established a permanent DHCP entry for this PC (and a couple of other devices with specific IP address needs for port forwarding purposes), it still seemed to be refreshing it. I’ve reset the lease time to 1 full day for now, and when I did so, it appeared to (visually) clear the list of permanently leased IPs. . . but when I try to add this PC’s MAC address again in its old slot, I’m told the slot is already reserved. Soooo. . . dunno. Lol.

Anyway, the other error message I was getting () lead me to here:

Best I can think is that something (perhaps the outage + reconnect with temporary lack of IP) was triggering MS to see my network connection as a new one and try to ping that NCSI server to establish connectivity to the outside world, and then it failed to do so as it was still in the process of getting an IP leased back to it. . . thus the error logs (DHCP lease expires, PC loses IP and connectivity, NCSI fails a quick connectivity check, and then the PNRP service tries to get out to my HomeGroup but can’t, all before my router re-assigns the spot to the desktop).

Still no idea why this suddenly became an issue (again, hadn’t happened until about two days ago, and I know that I haven’t been in the router to reduce the lease timer!), but increasing the lease timer has gotten me past two half-hour marks without a cascade of errors, so I guess it’s fixed? I’d still love to get a permanent assignment correctly working in the router as it was previously, but once a day is better than once an hour at least.

What if you gave your PC a different static IP (not the one you used before)? And then cleared out the reservation at

While once a day is certainly better than once an hour, it’s still sort of weird. And I hate weird issues like this when they happen on my pc.