Could I have a bad SSD?

For Christmas I gave myself the gift of a new Corsair 750W PS and a Samsung Evo 850 250GB SSD. I installed these parts about a month later, putting a fresh Windows 7 install on the SSD and porting my Steam library over to a 1TB SATA drive (not new, but not very old either, and freshly reformatted prior to porting over the library). For a few weeks everything seemed perfect…

…then about a month ago I experienced a crash while playing Grim Dawn. It locked up the PC completely. After rebooting there were some issues with Steam. At first it would say it needed to run an update, but the update never seemed to finish. Then I would try to reboot and the PC would get stuck on the Windows screen at boot. Turning it all the way off and waiting a moment, then powering back on seemed to fix the boot issue, but Steam was still messed up. I eventually had to clean out my Steam directory of everything but Steam.exe, then run that to reload Steam.

That seemed to solve the issues for a few days, but now over the past couple of weeks I have experienced A LOT of crashes and lock-ups while doing various things including trying to extract and copy a Mount and Blade mod from a RAR file on the SSD to the Steam directory on the SATA drive. At first I thought the issue was the SATA drive, as after a couple of lock ups and reboots it would run a chkdsk on F: (the Sata drive). But then I started seeing lock ups even when I was only accessing the SSD, not running Steam or accessing anything located on the SATA drive.

I suppose it could be a bad SATA cable, and I will bring one home from work to swap out, but I suspect the SSD itself is somehow going bad. The issues seem to occur no matter if I access the SATA drive or not. When it happens it essentially locks up iexplore.exe, the Windows Explorer, and I cannot close the application or shut down the PC, even with task manager. Sometimes transferring or extracting files will trigger it, other times it is random. In all cases though the PC is thoroughly locked up, and requires a power button reboot to come back to life.

Aside from switching out the SATA cable on the SSD and maybe removing the SATA drive altogether temporarily (to test if the crashes still occur with only the SSD in place), does anyone have any thoughts or suggestions? Thanks!

P.S. - I ran scans with Avast and Malwarebytes, I do not appear to be infected with anything virus or malware related.

I think Samsung have a tool to test the health of their drives. Give that a crack. The cable could be the culprit as well.

It’s called Samsung Magician. Definitely worth a download if you suspect your Samsung SSD.

I second the Samsung Magician software. I have the 512GB version of your drive and it’s a handy tool to keep installed.

Installed Magician, thanks for the recommendation. I used it to set configuration to “performance”. Also tested the drive and it completed the tests.

I think at least part of the issue may be AHCI. I’m running a pretty old mobo, MSI 785GM-P45, and I’m not sure it supports AHCI for SSDs. Right now my SATA is configured for IDE. In the BIOS the only option for AHCI is under “Raid Mode” in the SATA configuration where the choices are IDE, RAID and AHCI. When I’ve tried switching that to AHCI the PC boots but as soon as Windows begins to start the PC reboots itself. I don’t think the BIOS version of AHCI is compatible with the SSD. I’m running one of the more recent versions of the BIOS for my mobo (which granted is still dated 2010) and while there is a 2011 BIOS the release notes say nothing about AHCI or SSD compatibility.

Still, this drive was working just fine in this system for weeks prior to that crash mentioned above. I played Grim Dawn and other games (my Steam library is installed on the SATA drive) for hours and hours over a couple of weeks, and transferred files and used various other applications on the system with zero issues. Now suddenly everything seems to slow to a crawl at random intervals. Sometimes it recovers, sometimes not. Transferring files between the SSD and the SATA drive is no longer an option. I tried moving a 700MB RAR file as a test this morning, and while it did eventually move, it took forever, zooming through the first 300MB, then pausing for a long time, then catching up, then pausing again near the end before finally finishing. I suspect this is what’s happening every time the system stops responding, it’s simply paused in attempting to transfer whatever data needs to be transferred, either between drives or just on the SSD in general.

Very frustrating. At this point if it continues I am probably going to dump the SSD and go back to an all SATA system, including yet another Windows clean install (such a huge pain in the ass). I’ll then wait to put the SSD back in until I can afford to upgrade my mobo and processor (probably months from now). In the meantime I’ll likely RMA the SSD just to be sure I’m not stuck with a lemon after the warranty runs out.

When my first SSD went bad, it was causing random crashes and BSODs that did not go away until I replaced it. No diagnostic tool ever told me it was going bad (it was a Corsair not a Samsung, maybe their diagnostics are better), it was just the old-school isolate the problem component technique. Took about 3 months to figure it out, I think in part because I really didn’t want it to be my SSD.

Check your windows event logs. If nothing there, seems much more likely to be the power supply to me.

A bad cable connection is the cheapest and easiest option to troubleshoot. Unplug and re-plug the sata and power cables into the drives. Since you installed a new PSU too, it wouldn’t hurt to double-check all of the power cables.

Also, try using different sata connectors on your motherboard.


Thank you stusser. You know, System Event Log is the first place I look at work when a server or client PC is having issues, and yet somehow when I’m at home working on my own PC I never seem to remember to check logs before going off on a wild tinker binge. Of course as soon as I followed your suggestion guess what I find?

[li]The driver detected a controller error on \Device\Ide\IdePort0.
[/li][li]The driver detected a controller error on \Device\Harddisk1\DR1.
[/li][li]The system failed to flush data to the transaction log. Corruption may occur.
[/li][li]The device, \Device\Harddisk1\DR1, is not ready for access yet.

Dozens of instances of these four errors littered across the past 30 days, which matches the timeframe I’ve been having ever increasing issues. Tracing the port and disk references matches back to the SATA drive. So, I’m looking at one of three things:

[li]Bad SATA cable to the hard drive
[/li][li]Bad SATA hard drive/controller on the drive
[/li][li]Bad SATA port on the mobo

Easiest thing to swap out first is the cable, which I have spares for here at home. So I did that last night and thus far have seen no recurrence of the errors in the log and have successfully transferred an 800MB file back and forth between the drives quickly and without incident.

Even if it does turn out to be the SATA drive, I have working spares I can replace with as well, and if it’s a bad SATA port I have 2 unused ports I can switch to, so at this point it looks like I can successfully troubleshoot and resolve the issue. I’m glad it appears not to be the SSD or mobo after all, as I want to keep the speedy SSD and don’t really want to get into the expense and effort of a total mobo/processor replacement just now (my quad-core Athlon II X4 may be old, but it’s plenty good enough for now). I do wish the mobo supported AHCI for the drive, but it seems I can live without it and still have decent performance until such a time as I upgrade.

Thanks everyone for the suggestions and advice!

Yep, try switching out the cable and port. If not, you got a bum drive.

Also, immediately backup the drive.

I’m pretty sure I read somewhere you need to be off IDE and using AHCI for SSDs. I also found out how to change that setting by altering the registry, so you don’t have to do a reinstall of Windows. I did this on an Asus M4A785 motherboard. so it does work with an SSD now. I’ll have to look for the link to that registry change and post it later if you want it.