Crimson Skies Lockup/DVD Problem

Hey Folks

I’ve managed to overcome my vast lack of coordination and have been enjoying Crimson Skies (easy mode). Now I seem to be experiencing my first ever XBox lockup (or it might be a DVD problem).

I’ve made it to Arixo and I am on mission 6 or 7, the one where you escort the Zeppelin out into the desert. I did all the basic missions in Arixo. I just successfully completed the mission where you escort the zeppelin and fight off Red’s Gang and Los Muertos. At the end of that mission you fly into the Pandora and it shows the start screen for the next mission.

When I hit A to proceed with the next mission, it goes to the loading screen and just stops. It doesn’t load at all. After 30 seconds I get an error message that says “there is a problem with your DVD it may be dirty or damaged”. I tried 3 times and each time I get the same failure to load. I tried removing the disk, restarting the XBox, no luck. I inspected the DVD and it seems unharmed: it was fresh out of the box at the store and I havent scratched, spilled or done anything bad to it. I don’t see any visible scratches or smudges. Still doesnt work.

Any ideas? Does this sound like an XBox or a DVD problem? Am I going to have to take my DVD back, or is there some way to fix this? Has anyone else had similiar problems?

Any help appreciated,

Dan

It’s happened to me a few times as well. In punctuated bursts however and not at any specific focal point in game progress. Once after an online session, a couple times during the first leg of the campaign…(I’ve only just reached Arixo last I played Single player)

I’ve been hearing reports of it happening to others as well. Game has been acting very kind over the past couple days for me, however I’ve only touched multiplayer this past weekend.

Dunno if a new copy would outright help or not, but Crimson Skies has not been the only game to give me this error in recent weeks on my end. I fear for my aging Xbox…not even 2 yet and already showing signs of wrinkles.

Well I just checked the Microsoft forums and apparently this is a non-uncommon problem. The forum dwellers were claiming that boiling the CD in water for 15 seconds would fix it but I have a very hard time believing that. I’m certanly not going to boil my CD without more info than that :).

So its a problem. Whats the solution?

Dan

Boiling a DVD? That’s just so medieval. They were having me on, right? Right?

Nah, boiling discs is actually a solution that is mentioned quite a bit. Think of it as a way to clean out the pores or something.

I’ve never actually done it myself, so I can’t outright recommend it. But I’ve been reading about people doing it for years…

The boiling trick works.

I had the same problem with Xbox SSX3. Washing the disk in warm water worked for me.

I don’t have an Xbox, but recently I deep-fried my Baldur’s Gate CDs and breaded them, with just a dash of paprika mixed in. Tasty!

I was having similar problems with my copy. I couldn’t see any physical damage to the disk. I exchanged for a new copy and no longer have any issues.

I have boiled two of the xbox magazine discs and both worked flawlessly afterwards.

The process is this:

  1. Get the water boiling in a pan big enough to hold the DVD lying face down.
  2. Make sure you have a hook (paper clip, etc.) to get the DVD out of the water before you put it in.
  3. Place the DVD in the boiling water with the readable side down for 10-15 seconds (it will stay on top) then take it out.
  4. Dry carefully. I used a paper towel.
  5. Try it in the Xbox, it should work perfectly.

– Xaroc

I would recommend drying the CD with a clean cloth instead of a wood-based product like a paper towel, if you are trying to avoid scratches. Make sure it is indeed a completely clean cloth, and not just the front of your shirt. This is because most of us use fabric softener on our clothes - which is basically like lotion for your clothes. If you use that on the disk you will smudge some of that fabric softener residue onto it.

I had an xbox live beta disc that was slow loading/skipping all the time. I did the boil trick and it worked perfectly aftewards. I was hoping the boiling days were over.

Why does boiling the game DVD fix the problem? Does it give the disk a really good cleaning or is there some other effect?

Bonus Question: What was the person who figured this out thinking when he decided boiling a $50 game disk was a reasonable next step to troubleshoot a disk read problem? :D

Does boiling work for just Xbox DVDs, DVDs in general, or optical media in general?

Remember, above 2000ft, you must use the special high-altitude instructions for boiling CDs.

Brute Force locked up on me mid-game once, but I thought it was a bug. You don’t see them often in console games, but they DO occur.

I’ve been thinking about picking up Crimson Skies. I didn’t know it was out yet :).

All I know is I first tried to clean the disc every possible way: cleaning solution and motorized cd cleaning device, warm water, etc. Nothing fixed the disc until I boiled it. From what I’ve read they say it removes some film that is on the disc. Who knows. I wonder if boiling has any long term effects. Maybe I should pop that beta disc in and see if it still plays.

Alternately you can put it in the microwave for 10-15 seconds. Make sure you’ve got the lights turned off, and tell the kids to come watch.

You know, the game runs FINE up until this specific point. I have a different save game and that loads up fine. I can start a new game. I can do multiplayer.

I just can’t continue the main game I was playing :(.

I wonder if starting over would work or if I would be stuck at the same point?

Part of me thinks I should delete all my saves and start totally fresh. The other part thinks I should return the disk to Gamestop for a replacement. I still have a few days left…

Dan

Did you happen to hop onto Live for on-line play after saving that game? Apparently there’s some sort of glitch that hoses your saved game.

http://www.gonegold.com/ubb/ultimatebb.cgi?ubb=get_topic;f=12;t=007680

Also, is your XBox from launch day? The initial batch of machines had a crappy DVD drive that will now frequently give the dreaded DDE. It happened to me, and I had to call-in my Best Buy PRP and get a new one. Haven’t had the problem since.

Of course, I’d never tried the boiling method . . . in fact, I’d never even heard of it until I read this thread.

I don’t have Live yet so no I didnt do that. I did try split screen which works fine (although it was just me messing with both controllers).

As for my XBox, I bought it this year when KOTOR released and I havent had any prior trouble with it. I didn’t experience any of the lockups or weirdness that others had with KOTOR, and the other games I tried (Baldurs Gate Dark Alliance, Buffy, Indiana Jones, Otogi) all ran fine, although I didn’t play any of them very much.

Perhaps I should try taking the disk back and exchanging it.

Dan