D&D & sex: creation & relations

Title D&D & sex: creation & relations
Author Rudy Basso
Posted in Features
When November 27, 2012

"I've never played D&D with a girl before," James confessed when I first told him that Audrey would be joining us. "I don't want her to feel uncomfortable or anything; it can get kind of juvenile." "Are you talking about that one time you farted?" I asked..

Read the full article

She even asked me if I play Call of Duty.”
“Yeah, I know, but still. It doesn’t sound like she’ll be the judging type."

Love it!

Okay, the drama unfolding here is quite entertaining. Ladies add an interesting angle to the game, and my current group has a couple (well, one was off-and-on).

Though... I have to say that I'm getting progressively less thrilled with what I'm learning about D&D Next. It sounds like a half-assed attempt to mash 4e and Pathfinder together.

Ladies tend to care more about the point of games rather than the mechanics. And in multi-player strategy boardgames, all the guys in the table want to be nice to them. They're awesome opponents!

Point of clarification: The bit on backgrounds in 4e is only technically (aka "the best kind of") correct. There's this thing called "themes" that do add traits and options based on your background (such as nobles with servants), and the backgrounds (or "specialities" as they're called in Next) were are a continuation of this (and were originally called themes). For those who are interested there's some interesting blogs on the development process from Mike Mearls in the Legends & Lore column on the WotC site: http://www.wizards.com/dnd/Arc...

We now return you to your scheduled programming. These are fun reads, Rudy.

I can see how you can come to that conclusion based on the presentation here. My impression from the development blogs and the playtest package (which can be accessed here: http://www.wizards.com/dnd/DnD... gives me more of a "AD&D 2e with a sane resolution mechanic teams up with Earthdawn"-vibe. Which I think is a good thing.

Bleh, remove the ) from the link to get it to work.