Defective mouse?

I have a Logitech trackman wheel mouse. Lately, my mouse cursor will freeze at random times when I’m web surfing or playing games. I never had a problem for about a year and a half. I can fix the problem by either rebooting or unplugging the USB connection and then plugging it back in. Do you think the mouse is defective or is there something else going on?

Did you install anything that could conflict with the drivers? Also, completely removing the drivers and installing them again might help in case the problem is related to that.


Not that I know of. I have tried to remove the drivers and reinstall them but I still have the problem.

I get this with my Logitech cordless on occasion. Changing the batteries helps lessen the frequency.

Any other USB device hooked up? The USB port gets polled pretty frequently so other devices can interfere sometimes. I’d reinstall the drivers as suggested too.

TOTALLY remove all the Logitech software from your machine, reboot, let windows recognize the mouse, install Logitech drivers when prompted, reboot, see what happens.

BTW: This post belongs in the Hardware Thread, not the gaming forum.

I get this with my Razor Diamondback. At work, our techs are working on this same exact issue, due to the fact that everyone’s mice keep doing this.

USB mouse? By chance do you have an external USB hard drive hooked up (or an ipod?)

I solved a ton of strange problems (mouse and keyboard stopped working etc) when I stopped plugging my ipod in constantly. It’s also possible you have an older machine having issues with the USB 2.0 ports.

I’ve had about 8+ Trackmans over the years of various types. I’ve only had real issues with one and that was very similar to what you are experiencing. In my case4 it turned out to be a USB problem.

Yes, it is a wired USB mouse. My computer is about 2 and 1/2 years old and has four USB 2.0 ports. I do have an external USB drive hooked up, but I don’t turn it on. Could that still affect anything? I did recently replace my Geforce 6800 Ultra with a Geforce 7800 GS AGP. My problem may have started after that, I’m not sure. Could that have any affect?

I meant to post this in the hardware forum.