Deus Ex under Windows XP running fast?

About 2x, by my estimate. The game works well enough, but dialogue, movement, etc. are all doubletime. Anyone know of a fix for this? Running it on XP Pro, Radeon 9000 mobility card, 1.8ghz laptop. Game is patched to 1014.

Thanks,

H.

I installed it a month or two back and it ran perfectly. This was using XP Home, XP3200, 1 gig ram and a 6600GT. I’m guessing your video card is the issue.

My only issue is at 1152xwhatever the UI is nice and small but when I increased the resolution to 1280x1024 the UI jumped up in size as though the game were running at 800x600. I read up on it and apparently this was hard-coded into the game itself so no way around it.

Weird workaround on laptops: change the monitor powersaver settings to Home/Office, and it fixes the problem.

H.

Someone over at GWJ mentioned the same problem just a few days ago.

In case anyone else gets stuck in this situation, that solution was to bind a key (in the user.ini file,) to the command string that enables cheat-mode. I can’t remember it off the top of my head, but it’s long. Then I input the cheat ‘slomo’ which allows you to adjust the game speed. What you set it to is going to depend on your CPU speed, I would imagine, but for me the setting “slomo 0.425” seems to be just about perfect.

-Julian

Whenever I run Deus ex I always have problems. The solution every time has been to roll back DirectX to the version that is on the CD.


Glass Bong

While I have no idea whether this will fix your specific slowdown problem, I would recommend always running DX in Glide mode, using the 3rd party Glide Wrapper drivers (I recommend Zeckensack’s). The Direct3D mode is awful, and doesn’t even look as nice as in Glide (colours seem more vivid in Glide). HTH.

I had this problem on my dual core AMD setup. I set the deusex.exe process to use a single CPU, and it fixed the problem.

-Chris

I’ve had this problem in a few different games on my laptop. The power saving features cause the laptop to dial down its CPU speed when it’s idling. When you start the game, it checks the CPU speed to see how fast the game should go. Then, when the game gets going, the laptop goes “Shit! Full power to the CPU!” and dials the speed back up. Because the game checked the speed when the CPU was slow, the game runs too fast.

EDIT: Hah, I didn’t even realize this was an old thread.

Holy mega necromancy!

More possible solutions:

  1. Update graphics card drivers
  2. enable v-sync

I had same problem and tried turning off power management, set affinity to one cpu, and have a program run at 100% cpu but what finally made it work was graphics drivers. I noticed the game went faster when i was at less graphics intensive areas. Could even be v-sync.

I VOTE YOU OFF THE FUCKING ISLAND.

Zombie thread! Why does it seem as though someone dredges this up about once a year?

Because people here are OBSESSED with zombies.

I’m giddy with anticipation of DarkUltra’s second post.