DHCP Service won't start on Vista machine

Hey guys…

I’m trying to help a guy at work with his home computer…DHCP Service isn’t started, and won’t start.

Even when I run the Services page as administrator, when I go to start DHCP it gives an “Access Denied” message.

I’ve googled, and found several people having this problem, but no fixes.

This is the closest thing I found:

The one time where I noticed how useful Fast Switching is, I was trying to figure out why a certain security policy was causing various services in Vista to fail to start. Services like Windows Time and the DHCP Client simply wouldn’t start, saying “Access is Denied”. The upshot of this was the machine wasn’t seeing the network or anything, so accessing the machine’s logs, file system and registry wasn’t possible remotely. However, as with many who are roadtesting Vista, I keep my machine in a strictly embargo-ed, isolated OU in the Active Directory, so security by default wouldn’t let me access it. Fortunately, before the services failed, I had enabled the local administrator account. So, what I did was Switch away from the account and log in as the administrator account.

By the way, as an aside, if you have a machine called BLAHBLAH, the login you’d usually use for a local account is “BLAHBLAH\administrator” (as the domain is the default context for logging in). A much faster way of logging into local accounts is to use .\ as in “.\administrator”.

Anyway, as administrator, I could change various settings I obviously couldn’t do as the other, non-administrator account. The error, “Access is Denied” made me wonder if this was a ACL permission issue. I first tried to start the DHCP Client service as administrator and it failed. I followed a hunch and went to the Services registry key (HKLM\System\CurrentControlSet\Services) and found the DHCP Client key. I figured, it was trying to start this service as Local Service. Therefore, maybe there was a permissions issue with Local Service and this key. It turned out to be correct - adding Local Service to the DHCP Client registry key with Full Permissions allowed me to switch back to the other account and the service started correctly (I should point out, this was tried very late on today, so as yet, haven’t got an adequate explanation as to why Vista’s playing up like this…).

(Here is the full article, but that was the only relevant part.)

Problem is, I’m not experienced enough actually EDITING a registry to know exactly how to do that. I’ve found the DHCP key, and there’s all kinds of stuff in there, but I don’t know how to upgrade the Local Service account to Full Permission in there.

Ideas? Help? Another solution would be welcome, too, if someone knew of some other way to fix this, but it sounds dead-on like what I’m seeing, so I think I’m close…

Wow, did I really stump you all? Lol. That never happens.

I think this was fixed in SP1…

I’m not an expert on this issue, though.

Heh, which isn’t very helpful, since I can’t download the Service Pack, lol.

I’m hoping someone knows how to update the registry real quick to give the appropriate permissions to Local Service, or has some other suggestion. shrug

I will look into other ways of getting SP1, though…thanks for the idea!

Update: Service Pack 1 installed…I am having the exact same problem as before. Does anyone have any suggestions on how to resolve “Access Denied” when trying to start DHCP service?

Try running ipconfig /all from the command line and maybe that will tell you what’s going on. Maybe try ipconfig /renew.

Ipconfig /renew gives an error “the RPC Server is unavailable.” All Remote Procedure Call services are running on the computer. As I said, the DHCP Service (As in, Control Panel --> Admin Tools --> Services --> DHCP Client) isn’t running, and I get an “Access Denied” error when I try to start it, so I don’t think the machine is able to acquire an IP Address from the ISP.

I will paste the ipconfig /all readout…most of it doesn’t mean much to me, but if it helps anyone diagnose anything, awesome.

Windows IP Configuration

   Host Name . . . . . . . . . . . . : beaucallendePC
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) PRO/100 VE Network Connection
   Physical Address. . . . . . . . . : 00-17-31-DA-F2-CE
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::286f:76cc:4d78:4b7f%8(Preferred)
   Autoconfiguration IPv4 Address. . :
   Subnet Mask . . . . . . . . . . . :
   Default Gateway . . . . . . . . . :
   DNS Servers . . . . . . . . . . . :
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter Local Area Connection* 6:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
   Physical Address. . . . . . . . . : 02-00-54-55-4E-01
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 7:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : isatap.{F5A1F190-B467-4F9A-B1F0-872A76C99
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

For that registry thing:
Start->Run “regedit”.

In the folder structure on your left, browse to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Dhcp.
Right-click this dhcp item on the left (the registry key); in the menu, select “permissions”.
On the dialog, click “Add”; now fumble about until you have added the “Local Services” thing. (To locate that, click Advanced, then Find now). For that user, check “Full control”.

Wow…You provided me EXACTLY what I asked for, so thanks very much! I can’t believe I never saw that “permissions” in the context menu.

Sadly, it’s still giving me “Access Denied,” so if anyone has ideas as to why the DHCP service might not be starting, bring 'em on.

But thanks, red guy…You did provide exactly what I asked, exactly what I EXPECTED to solve the problem. I appreciate that!

I’m wondering if I just need to reinstall TCP/IP and DHCP services…not that that’s an easy task, but it’s what I’m considering trying next.

Keep the suggestions coming, if you guys have any other ideas. I’m flailing, now…lol.

Can you use system restore? Vista’s System Restore is much better than XP’s in my opinion. If this happened recently, you can roll back everything to when it was working and it should take care of it.

I’ll check and see if there’s a checkpoint, and ask him if he’s okay with that…that would be the easiest thing to do, at this point. He said it worked fine when he had DSL, but when he moved to cable it started acting up – which doesn’t make any sense, unless they had a static IP set when he was with DSL.

He also just recently upgraded to Vista, but I’m pretty sure that was back when he still had DSL, and it still worked…just fleshing it out with additional details.

I’ll check on the system restore thing.

The fact that he switched from DSL to Cable raises some flags. Is he still using the same router? Is it connecting to the cable modem ok? Were there any TCP/IP settings in Vista that were custom for DSL that have not been reconfigured? Maybe Vista isn’t pointing to the right DHCP server at all.

Has he tried contacting customer support? I know that can be a pain, but they can walk him through the correct TCP/IP settings and probably his router settings as well.

He’s had two technicians out there…they don’t know what’s going on. He brought it up here to work for me to check it out, and he’s not getting a connection here, either. The TCP/IP settings are all set to automatic…he isn’t using a router. I’m stumped by the fact that DHCP won’t even start. I know that’s the root of his problem, and I’ve found lots of articles online where people were having the same problem, but none of them has been able to “fix” it. Some did a system restore (I’m not sure his will have a system restore point where it will actually work, even), but nobody has FIXED the issue that I’ve found. And that’s irritating.

I wonder if when he was on DSL he was using a static IP address…that would explain why it was working then, but isn’t now, if his DHCP has never worked.