"Display driver stopped responding and has recovered"

Do you have a USB stick you can use for a boot drive?

I bought an HP laptop with a 9800 chipset that had this problem out of the box, no matter what drivers or bios version it was running. After searching the error message online, I came to believe it was the video chipset and returned the thing before my window closed. The HP laptop I got to replace that one was a slightly different model number that has never reported that error.

I have no idea if it was the case, but in searching online I found someone accusing nvidia of producing a bad batch of 9800 chips (something about the layer separation being iffy due to substandard raw materials) and allowed them to be released into retail because the failure rate wasn’t high enough to rate a recall.

Return the Nvidia card, buy a Radeon 5870. Problem solved. I shit you not, this happened all the time with the newer Nvidia cards we had at my last job. Switched to ATI, and it was gone.

Coincidentally, the “disable Aero” suggestion above actually solved it for some people. Nvidia has dropped the ball on this card generation, whether it be poor drivers or poor hardware.

I don’t know if I just got lucky, but I went to the actual game directory and directly ran Crysis64.exe, instead of just running it from Steam.

I played for about 20 minutes with no crashes… I wonder if that was the problem?

I’m going to be going through Stalker Pripyat tonight, I’ll see how stable that is…

FWIW I had this problem and it turns out my card was actually dying. A couple weeks later I got tons of artifacts and then it just stopped working. Geforce gtx 260.

Ugh I hope that’s not the case. I just got this damn thing 5 months ago.

Mine was less than a year old.

Or a 5850 or even a smaller card. This is a good opportunity to upgrade to a card that actually supports modern DirectX versions, and is faster and draws less power to boot.

As a recovering (SPCR) silent PC freak, I am more than happy with the idle noise of my Radeon HD 5850.

So the latest thing to happen to me was this

I finally allowed that incredibly annoying nagware acrobat installer to update. My pc bluescreened. I then tried to download the impulse client, and it said the file was corrupt when trying to install it. I redownloaded, and my computer bluescreened when trying to install the new download.

Windows then ran a pre-bootup chkdsk on my c drive, and it looked like it found some corrupt files. Unfortunately it didn’t pause long enough for me to read the chkdsk report and just loaded up windows again.

After this I was able to download the impulse client and install it without a problem.

So what does that sound like? A bad drive? Bad ram? I have tried reseating the ram and the videocard.

I just built this system 3 days ago with all new parts other than the videocard.

The only time I had this issue persistently also turned out to be a defective card. It was a new, at the time, 8800GTX. I did an RMA swap with the manufacturer and the problem went away w/ my replacement card.

I am getting this problem as well, on an 8800GT. I pretty much never had any issue like this with XP, and had to upgrade to Vista and run into it all the time now. At one point I did think it was overheating (the CPU, not the video card) because I discovered the fan power cable got stuck in the CPU fan so it wasn’t spinning at all. But yeah I still get it with updated drivers.

However, turning down a lot of graphics settings seemed to help a bit, though for some games not enough. TF2 works fine though, and L4D most of the time. DOW2 though had some issues till I turned the settings down by a lot.

So I was narrowing it down to a) Vista being shit and b) I need more RAM (running on 2GB). I hadn’t heard of this problem happening with Win7 up until this thread as I was thinking getting Win7 would solve all my problems. Crap.

— Alan

Test your memory.

Ok I performed win 7’s reboot and test memory (through mdsched), and it rebooted my system and tested the memory. It said there would be a memory report when it rebooted the system, but nothing came up.

Is there something else I need to do to see the results of this memory test?

You should probably get memtest86 to do the memory test. This sounds very similar to some problems I had a few years ago when I had some bad memory.

Ok, so I ran 3d Mark Vantage, and it ran through all the tests without crashing.

I checked out memtest86, and it says it doesn’t work on systems with 4gb or more of RAM. Is there another good, free memory checker?

Also, does anyone know where I can view the results of Windows 7’s own memory test once it completes?

Re: Win7 mem checker, it’s probably in the system log somewhere.

I assume the system log is in an obvious place, but I have no idea where that is being a new win7 user. Where is that?

This used to happen to me pretty regularly when I had an ATI card that used to run quite hot. Once I got better cooling on the card and in my case, the issue went away.

I had a similiar error over a year ago, chimed in here:


The “…has stopped responding and has recovered” rang a bell with me. I ended up basically replacing everything except the memory, and think it was the power supply all along.