Divinity: Original Sin 2 - Use more elements than Captain Planet!


#841

I can see why people are complaining about Reaper’s Coast. There is a huge difference even between level 13 and 14, and unlike in Fort Joy it seems harder to isolate particular units before fighting, in order to get the advantage of numbers.

I also get why that glyph puzzle might be incredibly annoying, but I figured that out mostly through trial and error and using 2 nearby jars.

What I don’t like is how some puzzles and/or quests don’t tell you anything useful. For example

Summary

Ereithne the trader wants a certain book. I procured it for her, but you’re supposed to sell it to her, not give it to her, which isn’t very intuitive.

And that doesn’t close out the quest.

You have to follow her to her tomb to close the quest, and all her juicy stuff has vanished…like huh?


#842

I agree many of the puzzles are just too much. You encounter someone at level 10, they give you a quest to go to the black pits which is a level 13 (or 14). And I’ve read so much about black pits that I definitely want to avoid it till I’m at or over leveled.

But then I do what I love in this game and that is just wonder & find elves who are grieving for their lost comrade, and go over a rickety plank bridge and have a tough voidowoken fight with a few magisters, who I then need to dispatch afterwards. After looting, and continuing on through a closed gate next to the farmhouse, I find this group of buildings with all these dead bodies and a pissed off magister whose level 13. So I spy the two towers, position my archer & mage up high, teleport the magister between my rogue and my dwarf and attack, but then FOUR MORE level 13’s come running up the hill.

OMG, what a fight, finishing off the mage I teleported just in time to try & engage the others. Thank god for stomp and my level 12 incarnate. Almost lost a few on several occasions with judicious use of heals and potions and knockdowns, and I barely scrape through. I walk down the hill to see these poor peasants kneeling with their hands tied behind their back. I free them, loot the nearby house and I’m not kidding, three steps beyond the house I get “Welcome to the Black Pits”. I had no idea I was even in the area.

But I hear that was just the first of several big fights in the area, so I’m still very cautious. Taking some trinket back to some guy in a cemetery is the least of my concerns. I just like wondering, leveling up & explore this world. Amazing how much they have crammed into this.


#843

That one battle a number of people complain about (Steam not here) and some cheat to get through, I won’t spoil but it’s the last one before you really leave the initial area, I used the tool associate with the cat and more than a few resurrect scrolls to get through it. My knight was the only member of the party that didn’t die, and I think it’s because she had an ability that that question provides.

Sure, sure when you can pick your family let me know. Things were actually going great though until he read how much money stealing makes… we’re talking 10k more than everyone else, and that’s just so far.


#844

I mean, it’s really easy to manage stealing if you communicate it, but if he’s going to be a dick about it not much you can do other than ask him to stop.

Basically one person distracts, he steals, then everyone runs far away until they reset.


#845

I just “Finished” this game. I put it in quotes because I never actually finished the game. I just deleted all my saves and uninstalled it.

My big gripes are the puzzles / quests that I frequently need to look online to solve.
And my biggest gripe are the bullshit combats. I was on the final combat, and then I got to phase 2 which raises the bullshit to new levels. Ill not go into details, but it was more than enough for me to simply nuke all save and uninstall. I am more than happy to google the endings rather than deal with that crap.


#846

Like many things in this game, the final fight can go different ways depending on the choices you make. Sounds like you made the tougher choice. I did too the first time, got destroyed, decided my current team wasn’t up to doing it the hard way and chose the easier ending.

My new party will absolutely wreck the harder ending even on the higher difficulty I bumped it up to; like most games I’m better at it the second time around and this party is much better designed and synergistic.


#847

giggle Like everything else in the game… there’s a trick to it. Got it on my second try.


#848

That fight is bullshit, but by that stage most fights even on Tactician are a cakewalk.

Puzzles and quests being difficult I would think are a good thing. Solve them if you want, Google if you don’t. Seems like win-win.


#849

@saracen31 I don’t mind difficult. That glyph puzzle for example required a bit of thinking and realising that depressing certain glyphs twice or 3 times would change the symbol.

My gripe is when quests don’t tell or, or really hint at, what you’re supposed to do.

That said, there’s enough to be doing that you can forget about one and do something else and figure the rest out later.


#850

I just left Fort Joy, but there are two quests I did not finish… Well there’s more than two I didn’t finish there’s only two I really care about. The first one is finding the phylactery. Second one is the hidden vault.

The phylactery room… Can someone give me a hint as to where the switch is? I explored most of the castle except for the room with five or six magisters in it, and but could not find a switch anywhere.

The hidden vault… That’s accessed from the marsh/forest area once you leave the castle right?

I’m enjoying this even if I am sort of cheesing the battles by using the gloves of teleportation to grab an enemy and plop him down in the middle of my party. But hey, all is fair in love and war.


#851

Make sure someone has decent Wits to detect hidden stuff.


#852

Yeah my character has a 16 in Wits so I don’t think that is the issue.


#853

Head down all the dead ends?


#854

Doh, I uncovered it but never went down into the revealed area, and that task got forgotten with all theother crap I was doing!


#855

Some of them are un-solvable without Googling due to poor feedback or outright bugs, though, which is the real issue.

Speaking of which, here are some public service announcements:

  • When using the silver levers on Bloodmoon Isle, make sure they’re in the inventory of the person having the conversation with the door - unlike other times you use the “Combine” interface, here it matters whose inventory its in. (I’ve also had the the silver bars flat-out disappear from my inventory before using them in the forge - don’t know any solution to that other than loading an earlier game.)

  • When you’re given conversation options labeled [Strength], [Intelligence] etc. - note that the character’s values for that stats will not affect the outcome. Despite the labeling, those are all Persuasion checks.

(What the stat affects is whether the option appears in the first place, plus the flavor of the result. Different responses might have different Persuasion values attached to them - the one labeled [Strength] might require Persuasion of 3 while the one labeled [Intelligence] might require Persuasion of 5 - but they’re all Persuasion checks.)


#856

I realized those conversations options were persuasion checks but I thought it worked by comparing the stat indicated for the speaker against the NPC. It’s just the persuasion skills? So you have no idea which option you have the best chance of winning? If so that’s really dumb.

I also just read that some persuasion checks will always succeed and others will always fail. Seems like this was a game system they redesigned during the development process and they didn’t really work it out thoroughly.


#857

I seem to be pretty badly stuck. I am wrapping up the swamps east of Fort Joy and found a Gargoyle’s Maze. I showed the Gargoyle my Ring of Braccus Rex and he teleported me past the maze to the Tower of Braccus Rex, which I happily looted. Now I can’t seem to get out past the maze. I’ve tried a fairly huge number of ideas but I’m stuck. Sadly I don’t have teleportation; I see how I could use that on the side by the beach to get out, but that’s not an option. I gather that the normal method is to work your way through the maze, opening the doors as you go. Or to have teleportation, or both.

Am I screwed here? I’ve tried every thing I can think of. I did find a skeleton with a skull that allowed me to open a single door but it didn’t get me out, and it didn’t let me access any other skulls (I’m doing the maze in the reverse order so the normal sequence doesn’t help.)

Maybe there’s something obvious I’m missing?


#858

Disregard the above, I got an answer by reading the old forums from the beta: it turns out that if you spin the camera around, there is a statue of Braccus Rex you can talk to. He tells you to begone and if you defy him, he teleports you of the maze.

Yet another lesson that I should spin the camera more.


#859

Also, you know you can teleport the entire party to the waypoints, right?


#860

Just an FYI, the final Driftwood Arena has a co-op specific bug that doesn’t end the fighting. I won’t spoil it here, but if you get to the point about being a champion like the fort joy arena, you might want to read up on it until the bug is fixed or you’ll wind up in a fight that can’t be ended, well it can but you’ve got to read up on how to do it.