Dropped laptop, battery not charging

I have a Dell XPS 13 and at lunch I accidentally dropped it onto a carpeted floor. I wasn’t able to catch it but I sort of slowed its fall with my leg. I thought everything was fine but I just noticed now that I have it plugged in that it says “38% avvailable (plugged in, not charging)”. The battery is obviously working because it seems to know that it’s plugged in and if I unplug it, it still powers the computer. Is it possible that something has come loose? When it’s plugged in the power doesn’t seem to drop however. So that doesn’t make sense to me. Are Dell XPS 13s fairly easy to open up and get access to the battery?

Any chance you have done a Win10 update recently, as there were some problems which show up like this with some of last years’ updates?

I went into the bios to check the battery and then when I exited I got this warning:

I charged it last night so I know it was working then. I didn’t check it when I plugged it in at lunch (before I dropped it) but I assume it was working then.

Here’s a summary of what I know.

  1. It charged last night and then I dropped it at lunch today.
  2. I haven’t had any Windows updates more recent than the last 10 days
  3. When it’s plugged in the computer says it’s plugged in but not charging (but the battery level doesn’t drop)
  4. When it’s unplugged the computer consumes battery as normal.
  5. When it’s plugged back in it doesn’t charge any higher than it’s current battery level.

Is it worth opening the back to see if something might be dislodged? It seems like I just have to remove some torx screws.

It’s possible something got wiggled loose with the drop. Please note you’ll likely kill your warranty if you open it up if it’s still under one, but here’s how you take it apart (and ostensibly put it back together):

edit -

If it’s charging UP TO a certain level and then stopping, nothing is likely loose and it’s a battery saving setting.

Actually I meant that it doesn’t charge any higher than the level it is currently at. So if I use the battery and it drops to 35% it will stay at that level. Kind of a roundabout way of saying that the battery doesn’t charge. Well anyways I opened up the back but unfortunately could not see anything out of place. Still no change.
One thing that I noticed is that when I start the computer up with the adapter plugged in I get the bios warning but when it’s not plugged in there’s no warning.

Is it possible that the actual plug leading from the power brick was damaged, not the laptop itself? That seems to be what the warning is saying.

Possibly? I can’t actually remember if the unit was plugged in when it fell. But it’s keeping it from losing its charge so it seems to be working in that regard at least. I’ve updated the BIOS and still no love. I guess I’ll try to see if I can find a different adapter and see if that works.

My XPS13 9350 just spontaneously started with the ‘cannot be determined’ screen, so it might not have anything to do with dropping it. I sweated bullets for a day, then thought ‘hey - USB-C’.

Just make sure you get a C to C cable certified to carry the power (they’re a bit pricy).