Elden Ring - George R.R. Martin and Hidetaka Miyazaki

I somehow didn’t realize that the signs had the effect of summoning NPCs. I.e. I triggered one on the first couple of runs, and made no connection with having done it and a NPC summon appearing. So then for the remaining attempts, I skipped the summoning signs entirely, and probably got a very different experience than intended…

Well, I went to him right after I gave Ranni her prize, and

He was dead. I picked up his ball bearing and clothes.

Right. I use one of the provided icons you can mark locations with.

Yea, that was what I assumed you found. He is involved in a couple other things if you deal with him earlier. When you first meet his ghosty version after talking to Ranni he asks you to come see him. If you do it will start one quest. Sellen asks you to talk to him at one point and when you do that is another quest line. But once you start Ranni’s and get to a certain point he just dies for some reason.

So I beat Astrel on the first try with only 7 flasks. I am amazed how much better this build works than my last one. Me and my mimic are literally kicking arse.

I am sure Maliketh will not be so obliging.

I went and saw him in his tower after talking with Ranni, and he gave me the item and instructions, I figured I’d do that after doing the Ranni stuff. Not sure what to do with what he gave me now.

Seluvis spoilers: As to what to do with the potion, either “nothing” or you can try showing it to Gideon Ofnir. Seluvis is a bad dude that is trying to convert people into his personal slave/puppets. His questline involved you helping him try to kill Ranni and turn her into his puppet. Progressing Ranni’s quest means Ranni uncovers Seluvis’s plot and she kills him. You start learning this stuff after you try to give the potion to Nephili. Since you didn’t do that yet, you’re not aware of his plans but you still basically initiated Ranni’s involvement without learning about his secret plot yourself.

As to what to do with the potion, either “nothing” and just move on with a random surplus item in your unlimited inventory, or you can try showing it to Gideon Ofnir.

I hate skeletons.

I killed Starscourge Radahn in two tries. I put my Meteorite staff away sometime and arm another Katana in my left hand to powerstance with my Moonveil just for the fun of tearing through a crowd of bad guys. I’m not OP by any means, I’m still only about level 110, but I don’t run run screaming like a little girl when I see huge bosses any more.

But I get into a catacomb filled with skeletons, and I KNOW I’m going to get surrounded by the damned things and killed. When I kill a skeleton I have a hard time targeting it on the ground to quickly finish it off. They are just a royal PIA.

I hate skeletons.

Has anyone had the problem of being in, say, a catacomb, and suddenly not be able to do anything but move? As in, can’t swing, can’t cast spells, no buttons are functional, all I can do is walk. This is PS5. Haven’t figured out how to break out of the problem once it hits.

If you activate a switch you get locked until the message goes away, but the game doesn’t bother to tell you the hotkey to do it.

Yah that got me killed a few times.

I played PS5 up through patch 1.03 or 1.04 and didn’t encounter any unresponsive parts.

Should be triangle to dismiss the message on PS.

Dying to forgetting to dismiss the message is such a universal experience that I’m convinced this has to be another case of From trolling the players. There’s just no way they actually could have missed it during playtesting, or not understood how annoying it is.

I’ve died to that a bunch in Bloodborne. It’s 100% an intentional troll move to leave it in.

Further Seluvis chit-chat

There is a Magic Scorpion Charm you can get from him and so far, in all my play throughs, I have failed to ‘keep him alive’ long enough to receive it.

Further PvP chit-chat

Had a wonderful several hours of playing my main yesterday. Now on another NG+ (4? 5? am losing track) I have a few goals in mind. I have had some success recently at finding PvP a’la invasions/hunters but all day Sunday it was off the charts. Specifically, when in and around Liurnia (west of the crab shack, south of the academy) there was non-stop invasions when I enabled Taunter’s Tongue.

Earlier in the day it was 100% me being invaded and I don’t think I was summoned to support anyone despite having the blue ring (and the white ring) enabled. And it was literally non-stop. There was no point in trying to do anything else when I enabled the tongue. So I just hung around spawning PvP invasions. I loved it! And I’m on record as wanting nothing to do with PvP but this was so much fun. Later on in my evening session there was a mix of me being summoned to help others who were invaded (blue) even when I had the tongue enabled but again, either way, invasions were pretty much the rule and non-stop.

So, I suck at PvP, but it was still fun even when I lost. Had some amazing fights. Generally if I was invaded, I tried to be on high ground and spot the invader coming. Give them a wave to let them know I’d seen them. Then we’d bow and buff (a’la dueling) and commence the fight. If I could stay alive long enough a hunter would spawn to assist me and that was usually how I ‘won’; getting it to a 2 v 1 battle. But, of course, if it continues much further a second invader would arrive and there would be 2 v 2 battle. I think I’ll keep trying to do this rather than duels as I liked the variety and randomness and choosing a defensible spot.

As unexpectedly fun as the whole day turned out it was an amazing source of runes for my character. Levels start to get hard to come by and I started the day at around 272. I ended the day at 278 doing practically nothing but invasions. I tried to do the math but there was no way to track how many individual invasions there had been. But if I was the winner 25% of the time (and that would be generous) and was netting, on average I think, 100K runes, AND it is almost 700K to level… well. That was a lot of fighting.

I keep meaning to spend some more time on another character I’d stopped leveling at 137 to be focused on dueling and PvP but if I can get this kind of action at levels 270 and above I think I’ll just stick with it.

Liurnia is where in my game most invasions occur. If I do anything in the opening area it tends to be gankers having a fight club.

I like PvP but I don’t like the preponderance of one shot weapons and builds in ER.

I’ve finished the first part of Ranni’s quest, given her the treasure I found, decided to do some wandering and looking for upgrade materials (ghost gloveworts, somber smithing stones) to get my newly found mimic scaled up as well as my Moonveil and Carian Regal Scepter (seems you have to really get it scaled up to equal the Meteorite staff, and as much as I use Rock Sling not sure I want to give up the Meteorite staff. So a wandering I go. I found Baaird under a evergaol (sp) and got him out, talked to Iij and discovered there’s some stuff gonna happen. OK,

ANYWAY I started exploring some areas I didn’t completely cover before and I found my way underground to the Ainsel River Well Depths. Lots of fun exploring, and was surprised to find something cool besides ant tunnels. Managed to kill the rock throwing bug thing, and realized, wait, I’ve seen this area in a video when I was looking up the Wing of Astel. Which I REALLY want to go with my Moonveil. I look around and I see, it’s up on a rail kind of thing up above me. But no matter how much I explore, I cannot find a way to get there! I did find the map of the area and it looks like I might could approach it from a different direction, but I can’t see how to get there. Went on down the river, found the big area with the dragon boss, killed him, but that just seems to be dead end.

Is there no easy way to get to that blade from where I am???

IIRC you’ll need to come at it from a different angle, but it won’t be hard and you have just achieved the prerequisites.

  • Do you remember there being an inaccessible section of the map near Ranni? Could advancing her questline have opened it up?

  • Visit Renna’s Rise.

Yea, the Ainsel River area has two parts which don’t connect, although I think it may be possible to get from the second part to the first, but not the other way around. You have found the first part.

Eventually if you follow Ranni’s quest it will lead you to that second part, although the means may not be terribly obvious.