Explain Windows sharing (win 10) like I'm 5 years old


#1

I can’t believe how much time I’ve wasted on this today. Nothing is working. What I want is to share my Steam folder with my son so I can copy games between him & me to reduce downloads as we play many of the same games.

So I go into file explorer & create a share:

I have went into Network sharing and clicked the following:

Private

Public

All Networks

And yet, when I try to access this share from my son’s computer it says “you don’t have permission to access…”

For the record, how I try to access it, is I go into file explorer on his computer and type in “//tman-pc/tmangames” and it shows it in the drop down before I even complete typing, and I select it.

It shows the share, but I can’t access it.

Any ideas?


#2

Humm.

You have the sharing set up and you can see the share, but you still can’t access. Maybe it’s something in file permissions? In the fist screenshot of the share tab that you put, go to the security tab and see if that looks right. Maybe give Users full control and see if that helps.

I’m just guessing here.

Oh, and on your son’s computer, you’re logged in as a user or an admin? I think I’ve gotten around this by using a the same user name and password as I have on the other computer. I’m just throwing out some ideas. Once you identify what the issue is, you can find a way to resolve it


#3

Oh, and maybe try a restart of the sharing computer and then make sure all your configurations are still in tact.

A restart always helps everything!


#4

Well, here is security:

and the sharing security:

I wonder if the fact that “everyone” is not added to the first tab is the problem?

So I add Everyone

When I hit apply, it goes through every single object on that drive and applies it, so it takes forever

(which while I’m waiting makes me wonder if I’m exposing this to the internet because when I say a long time I mean like 10 minutes )

And now it’s working.

I’m going to let this copy finish, but I’m still nervous on giving access to “everyone” even if only read.


#5

Just unplug the modem from router if they are separate.

Or unplug cable coax if it’s fused unit.

Wont help if someone had your WiFi but you know it’s only a steam folder with no write permissions

edit: WAIT WHY ARE YOU SHARING THE ENTIRE ROOT DRIVE instead of just the steamlibrary?


#6

When two Windows love each other very much…


#7

Instead of Everyone, why don’t you just give access to the account on your other pc?

In the old days, you would make a shadow account on your PC that matches the name of the account on the other PC. So if the other PC had user account “Son” on a PC named TMAN_SON-PC, then this would be the account: TMAN_SON-PC\Son.

And the shadow account would be TMAN-PC\Son.

You would make the password on both accounts match (I think), even if you’re not using passwords. Or I might be misremembering. But the idea is that you would be able to add your shadow account to the Security tab on your PC, then when your son remotes in from his PC, Windows allows it.

Now I think Windows has some sort of Wizard-based home network sharing stuff. You might want to try it. It simplifies all these configuration steps and gives you a password to add PCs to your network. You only use the password for the initial setup, then everything just works without passwords. This came out around Windows 7 time, so it’s relatively new. I remember feeling hesitant about it at first, but now I use it all the time. It’s not that hard to set up and if it’s still available, I heartily recommend it.

EDIT: or I used to use it all the time. Now we only have 1 pc in the house and the rest are all macs, so it’s a different keg of fish, but somehow they can all use one network printer. Good luck.


#8

There’s also some services that need to be running for the network sharing to work. If I can find the specific ones I’ll post it, but I had to do some digging and restarts when they changed it to get mine working again.


#9

These look correct.

https://answers.microsoft.com/en-us/windows/forum/windows_10-files/homegroup-removed-how-to-get-network-sharing-work/01277332-2916-4a68-853a-116696b20743

Good luck.


#10

Wait, homegroup was removed? Why did they do that? Was it deemed insecure?


#11

they removed it earlier this year. Not sure why.


#12

thanks I didn’t have a few services running.


#13

No problem. I was ready to murder someone when they changed it on me and my homegroups all broke. Complete pain in the ass until I found those services listed on some tech forum.


#14

What did you need to turn on? I’m just curious. I thought you said it was working?


#15

It was deprecated starting with build 17063 (existing Homegoups continued to work but you couldn’t create new ones) due to what they felt were better ways to share (I think I disagree with their assessment, heh). Feature was completely removed as of 1803.


#16

I am going to be doing a new computer build soon and I want to share my users/public folder. This new computer will have a different account name than my older windows 10 box.

So what I did was share my public folder via the advanced settings on my old box. (new box is not built yet, so I can’t test this). My old box;s main user is “silver”. On my new box, the main user will be “gold”. So I on my old box, I created an admin account called “gold”.

Now when I build my new box, and after windows is setup and the account “gold” is created as the primary account, then when I browse my network shares and see my old computer, I should see the public folder and be able to copy all the files from it to my new computer?


#17

That sounds about right to me.


#18

I have a new computer setup, and when I view my network I can see my old computer. However, when I click on it, it says that it is not accessible and there may be a permissions problem. I made sure they are both in the same workgroup, just in case.

Also, from my old computer I can’t see my new computer, but from my new computer I can see my old computer


#19

Did you follow becoming’s link he posted a few threads back?


#20

problem solved, sort of. Using my network shares by IP addresses worked. Why that was required, I do not know.