Explorer.exe issues

Recently i’ve been testing and uninstalling several different AVI converters. Suddenly, my system has begun acting extremely strange. Any time I try to open or even right click on an AVI or MPEG file, I get an error that forces explorer.exe to crash and shut down. In fact, if I even open a folder that contains an AVI or MPEG, I’ll get an error with explorer.exe or something called Dr Watsons Post Mortem Debugger, and the system crashes.

As you can imagine, this is extremely frustrating because I can’t even drop and drag, rename, move or view properties on these these files without explorer.exe crashing. Strangely, I can still open any media format through my Divx player software and the issue will not occur. So, if I want to rename an AVI, I need to open Divx, click on open file, and rename the AVI through that or some other program.

I’ve attempted reinstalling Windows Media Player 11 and this has not corrected the problem. I’ve also tried every form of virus detector under the sun.

Is there any way to just reinstall explorer.exe to a system?

It sounds like you have a munched codec, and Explorer is crashing when trying to preview the video and/or read the header.

You can try going to the Control Panel/Sound and Audio Devices/Hardware/Video Codecs/Properties and try removing some of the codecs you may have installed and see if that clears things up.

One of the applications you were trying out installed a plugin for explorer that is fucked up. The best way to check is to go to IE (yeah, I know) and go Tools -> Internet Options. Go to the Advanced tab, and there is an option in there for “disable third party browser extensions”. Check that, click okay, and restart your computer.

When it comes back up, try to do something that hasn’t worked to an AVI file. It will probably work.

That’s just to verify the problem. Go back into IE and replace that setting.

Oh, shit. I just remembered that with SP2 you can probably just go to Tools -> Manage Add Ons and you can selectively disable them. Use trial and error to nail down the problem one, and leave it disabled or delete the folder that it’s located in.


This problem actually occurs outside of Internet Explorer on my standard desktop. (Although the system will crash when trying to load an AVI via IE.) Are you saying the two are related?

You can try going to the Control Panel/Sound and Audio Devices/Hardware/Video Codecs/Properties and try removing some of the codecs you may have installed and see if that clears things up.

It won’t let me delete the codecs. When I choose remove, it asks me to confirm and wipes them from the list, but when I close the tab and reopen it the codecs are still listed.

If you get a stack trace and a module list it will be much easier to find the problem.

iexplore.exe (IE) and explorer.exe (the shell) are essentially the same thing, and plugins for one can adversely affect the other. The specific thing you’re describing – a particular file type causing explorer crashes when you RIGHT-CLICK on them – is, in my experience, always caused by a bad plugin. It’s possible that one of the applications you installed added something to the shell’s right-click menu for files of that type. For example, when you install WinRAR, it adds options to “Extract Here”, “Add to —.rar”, etc to the right-click menu. That is done with a plugin that is detectable/removable through IE.

Historically you would find the problem and remove it with Hijack This!, but after SP2, IE has the ability to disable those plugins on it’s own.

If you get a stack trace and a module list it will be much easier to find the problem.

Sorry, but could you explain how to capture this?

Also, on another technical forum someone posted:

regsvr32.exe /u shmedia.dll should solve it. If it doesn’t then revsvr32.exe shmedia.dll to restore.

Could someone decode that, please? I’m assuming he meant go to My Computer->Run->regsvr32.exe /u shmedia.dll
If so, this had no effect.

You’ve got to execute the command in the directory that shmedia.dll is located in. You should use the command line to navigate to that directory before you use the command, so as to be sure the file is there.

iexplore.exe (IE) and explorer.exe (the shell) are essentially the same thing

Not exactly. Iexplore is an app that uses trident to render html, download things, etc. Explorer.exe is your shell. They each have tons of hooks in them so that you can call other things. Making a shell extension is simply providing a dll with a series of exposed callbacks in it and registering them with various actions in the registry.

Whenever you get a crash you get a watson popup that takes a minidump of the process and sends it in to MS. “Tell us about this problem”. If you click on the little link that says “See what information this report contains” you will get a basic stack for the process and a list of the modules it has loaded.

The regsvr32 app simply takes the exposed methods of a dll and adds them to the registry so that the proper callbacks can be made. As for the Shmedia.dll bit, this depends on two things.
#1, do you have that dll on your system?
#2, is a call to that dll mis-mapped, causing your crash?

That’s what the stack trace module loadout is for, determining which call went wrong, and in what module.

That would be in the “Details” part of the crash notice that Windows gives you when a program crashes. When it asks if you want to send an error report to M$, tell it no and click on details. That should give you a clue as to what process dumped the stack.

:) :)

I can’t figure out how to copy and paste the information from the report. I can’t highlight it, or right click on it. The error signature is wmplayer.exe

then there is a huge list of modules:

Module 1: wmplayer.exe
Module 2: ntdll.dll
Module 3: kernel32.dll
Module 4: advapi32.dll…

all the way up to module 71.

This is insanely frustrating.
Any more help would be appreciated.

Not to be a dick, but did you try what I said about the Internet Explorer plugins? You never mentioned whether that got you anywhere. Failing that, PM me a log from Hijack This. Certainly the debugger can find the answer to the problem, but based on personal experience with several similar problems over the last few years, I think the problem is what I said – a bad shell extension.