File in use on Windows 7

There’s a video file on my machine that I can’t delete because it’s always in use. If I copy the file to another directory, the copy is also always in use (so I now have like 5 undeletable copies of it, for reasons I won’t go into). I assumed what’s happening is it’s trying to thumbnail the video and can’t for some reason (it has no thumbnail). But, if I close all the explorer windows and use the command line, it still says the file’s in use. Any ideas? There are things like Unlocker, but it seems to not support Windows 7, and I’m not sure that it would work on this kind of case, anyway.

Unlocker’s website says it support Windows 7, 32 and 64 bit versions.

Huh. Well, thanks. I was just going by the stupid “supported on” field on or whatever. That worked, thanks. Any idea what the problem was?

Doesn’t Unlocker tell you what locked the file before it fixes it?

Probably what happens is that some process locks a file and then is terminated abnormally for whatever reason and the file never gets unlocked. Why copies of a locked file would also be locked I have no idea.

Next time this happens you could try Process Explorer to find out which process keeps a handle on those files. From what you said that process is likely Explorer anyway, though. Sounds like an Explorer bug to me.

Yeah, according to Unlocker, it is Explorer.

In that case, maybe shutting down the Explorer process might unlock the file?

Of course, once you do this you won’t beable to access the file by normal means. So open up a command line window first.

Rebooting into a safe mode usually fixes this kind of issues and allows you to delete the affected files. It’s pain in the butt though, so if Unlocker really works (I neevr tried it), just use it.