Firefox issue that is driving me crazy! Help!

OK, I was using Chrome for a while to see if I liked it better than Firefox, but after a couple of years I came back to FF. That’s another story. But - I cannot get Firefox to open a mailto: link in Gmail in a Firefox tab. It always tries to open it in a Chrome Gmail tab. I went into the Firefox options, and under mailto: it has “Use ChromeHTML” (default) and no other option (other than always ask, which just brings up a windows explorer window.) I went into Chrome, and went all the way to the handlers in options and removed the one for Gmail. I go into Windows Default Programs, and there is nothing for mailto. But when I open the Chrome option for the Default Programs, it has 1 default for Chrome and that is the mailto. So I try to “uncheck” the check box next to it, and it will not uncheck. Arghhhh! So I uninstalled Chrome completely. Now there obviously no Chrome in “the system” or in program defaults in Windows. Yet Firefox STILL shows Use ChromeHTML as the default for mailto: with no other options!

Help! This is driving me crazy!

Additional info: I went into the registry and removed all instances of “ChromeHTML” - now that does not show up as the default (or at all!) in Firefox options/applications/mailto but there is no Gmail option either.

Now that you’re removed references to ChromeHTML in the registry, try to uninstall/reboot/reinstall Firefox?

Yeah, did not uninstall/reinstall but I think that is probably the next step. :(

Reinstalling won’t help, but you may want to try a fresh profile.

Damn. Uninstalled, reinstalled, still no Gmail option in mailto in options, just choose a program.

Seeking understanding: how will that create Gmail as an option in the mailto: options?

Doing some googling (a LOT) and in following some rabbit trails I find that there is no HKEY_LOCAL_MACHINE\Software\Classes\mailto in my registry. Specifically, no “mailto” in HKEY_LOCAL_MACHINE\Software\Classes\

Wondering if that is part of the issue.

This didn’t work for you? Looks like you can just type in the URL for GMail if all else fails.

No, under mailto in Firefox options I get “always ask” or “use other.” Use other just brings up a windows explorer window. Somehow I need to set Gmail as an option. For example, at one point it listed Yahoo Mail as an option.

Reset Firefox?

Yeah, I hate to do that because I envision having to reinstall all kinds of addons (and I had to use a trick with the new FF version to get Forecast Fox to stick to the new addon bar which had to be readded since Firefix decided we didn’t need an add-on bar any longer - that smells of Chrome (“we aren’t going to give you the option because we know what’s best for you.”) and then it still not working! LOL! Does the reset do something an uninstall and reinstall does not do?

I added Gmail manager and it had an option for the mailto, added my gmail account, but when I click on a mailto link now, instead of getting an IR window that says “can’t open no default mail program set” I get a Google window saying I must have cookies disabled (I don’t) and when I cleared the history, etc. it still gives the same window. I.e. that doesn’t work.

Somehow I SHOULD have a Gmail option. Like I had a Yahoo Mail option. But I don’t. Maybe reset is the next step.

I actually really hate Chrome, and issues like this are definitely why. I never install it any longer.


OK, just in case anyone else has this problem and does a search. I think the suggestion to Reset and to create a new profile (which reset does in addition to other things) would have worked, but I stumbled across this. Basically, find the mimetypes.rdf file in the Firefox folder, delete or rename it, and restart Firefox. Firefox recreates this file. That fixed it, I now had a Use Yahoo Mail and Use Gmail option. Clicking the use Gmail worked.

Apparently, Chrome hijacked that option and uninstalling Chrome did not release it. I had to uninstall Chrome (since in Windows Default Programs option it would not allow me to uncheck the mailto option in Chrome defaults) and remove all mention of ChromeHTML in the registry, then delete this mimetypes.rdf file and let Firefox rebuild it.

Thanks (and my wife thanks you because she has to sit here and listen to me obsess when I get a problem like this, LOL!)

That’s pretty ‘nasty’ of Chrome to do that? what a pain in the butt!

Yeah, and I found online others struggling with the same Chrome “hijack” issue. Some apparently did just what Google hoped - they couldn’t solve it so they went back to Chrome. Nasty indeed.

This is what I was talking about above - another example is that Chrome likes to “hijack” it being the default program for when you click on links even after you remove it so when you remove Chrome you will find you can’t click on a link (say in a Steam chat window) without getting an error until you fix it in the registry. Stuff like that seems super shady - Google definitely could make a better uninstaller, they just choose not to.

Well its installer is kind of shady to begin with, circumventing requiring admin privileges to install.

So with the Firefox 34 update I have one big like. Once upon a time, using the URL bar to search invoked a Google search, while using the browser search bar used whatever search engine was selected. Then, after some update over the past year or so, both the URL bar and the browser search box started using the search engine selected in the browser search box. This was irritating to me, because I liked to be able to have, at all times, a dedicated Google search via the URL bar and a selectable search engine in the browser search box. But now both searches were defined by the browser search box.

With FF 34, this is fixed. What’s more, clicking on the magnifying glass in the browser search box let’s you pick a different engine and kick off the search at the same time. Love it.

Strange thing happened after I updated to 34: Flashblock extension stopped working. I removed it, restarted Firefox and reinstalled it, and saw a message that said that Flashblock was no longer compatible with Firefox, and that Firefox had its own Flash blocker. But after uninstalling Flashblock and restarting the browser again, Flash was clearly not being blocked, and I saw no setting for this behavior. Then, a day or two later, I reinstalled that extension and suddenly it was working as expected once again.

Flashblock’s functionality is mostly built-in to Firefox now. Unfortunately not completely, so you still need an addon to control it.

Install the addon linked below and make the changes to about:config listed in the description. If the plugin notification bar annoys you, install the userchrome.css file too. Pain in the ass.

There’s also noscript (which you should be running if you care about security/privacy) but I don’t like its plugin blocking implementation because it’s site-wide and not per-element.