Firefox Quantum?


#41

Which version? I’m on 57.0.1 and everything is five-by-five.


#42

Yep, updated to 57.0.1 and it’s fine. At this point I think I’m back to being a FF user, I haven’t uninstalled Chrome yet but unless I run into something odd, I don’t see going back.


#43

Yeah, 57.0.1. Happened when I logged on today. Might just be me. Got things back in order since it made a backup folder.


#44

Thanks for the reminder on making a backup folder!


#45

The way things happen it’s a must. Actually I have a much older Firefox backup. Luckily whatever it did, it made a backup, thank dog.


#46

You should be taking regular backups anyway, ideally both to an online service like backblaze and locally with something like time machine or windows file history. Take this lesson learned and sin no more.


#47

I miss Tab Mix Plus more than anything. My tab flow isn’t as fluid now but I’ll take Quantum’s speed improvement and Firefox over Chrome any day.


#48

Most TMP functions can be done with other addons. Main benefit of TMP is it consolidated all the various customizations you might want in one addon, that is no longer available.


#49

Tried this last night now that there’s LastPass support and am really liking it so far. I’m going to try using it exclusively the next week and see how it goes.


#50

#51

Aside from getting used to no TMP, and the wonkiness of some add-ons like NoScript and LastPass that need more development time and/or me getting used to the new way of doing things, the new Fx doesn’t seem all that different from the old one. I guess whatever I do on the net isn’t affected all that much by whatever improvements 57+ brought. Or, at least, I just don’t notice them. Things work like they always have. Happy that I’m able to stick with Fx, though and that the changes weren’t all that difficult to get used to.


#52

The UI is a bit different and it’s supposed to be much faster, but the old Fx never felt particularly slow to me. /Shrug.


#53

I think the switch to the Chrome versioning a while back really messed with my ability to detect changes. Not sure that’s a good thing since it can’t generate any excitement when your new product looks and feels practically identical to the previous version.


#54

I did some clean installs of the OS when the Fall Creator’s Update released, and I decided to fly with Edge because EdgeHTML16 did introduce some speed improvements. Still, Edge can really take a long time with certain pages, and it really, really struggles if you, say, click on “show all comments” on a 2,000+ comment reddit thread.

So I decided to try out Firefox Quantum, and I’ve switched over. It’s a lot faster than Edge on my Surface Book 1, and it’s damn near instantaneous on my i7 desktop. It’s sort of crazy that Mozilla is the first company to really create a browser that takes full advantage of multicore and GPUs, but I can’t deny the speed difference. It even feels a heartbeat faster than Chrome.

Extension-wise, I’m okay. I only use ublock and LastPass. Yeah, the LastPass support is a little half-baked (I too miss the ability to copy a password in the menu options). I expect LastPass will improve that situation.


#55

Taking full advantage of multiple cores to render a single page is apparently a non-trivial problem. They invented an entire programming language to do it.


#56

I have had issues with this thing though, as in my Macbook wouldn’t properly sleep anymore. Disabling the multicore rendering (or a couple of settings that seemed linked to it, at least) fixed that issue.


#57

Anyone able to get the new NoScript to consistently save your site settings (Trusted, Untrusted, Custom)? It may be saving for some site but for many it’s not saving my settings. This seems to be a known problem, as there are many folks in the comments stating the same thing. This plugin is useless without being able to save. WTF is going on?


#58

Are you opening up the toolbar icon and making permissions permanent by clicking the clock icon or are you leaving them as temporarily Trusted?


#59

Maybe I’m not sure. I just looked at the drop-down menu and see that I can click the clock icon twice, for different settings, I think. One, either a smaller clock or a larger clock icon. The tooltip text for both say “Temporarily Allow (TRUSTED)”.

When I set it to the smaller icon it seems to be saving my setting. Thanks, I think that’s what i was looking for. Very odd UI and even stranger tooltips.


#60

Been experiencing similar noscript issues. Sometimes it seems to retain my trusted settings, but it’s not consistent and in one case, even with the trusted settings, it would still kill my ability to use a certain website. Ended up disabling it for now. Any alternative recommendations, other than uBlock Origin?

While I’m here, I’m also looking for a replacement for TableTools2, if anyone knows of one. Appears to have been abandoned.