Firefox

#1

I was disturbed this morning to open Weather Underground and find myself inundated by ads. Huh? Turns out that The Ad Block icon has disappeared from Firefox. Check Ad Ons, and I see that “Starting in Firefox version 57, only extensions built using WebExtensions APIs will work.” No more Ad-Blocker for me. Hmmm.

Two days ago I had to call Turbo Tax tech support because I was unable to download my federal return they did for me. Tech support solved my problem by… having me use a different browser than Firefox.

Not so long ago, sound quit working overnight on You Tube. A search found that it was a Firefox problem.

And I remember even back then thinking to myself, “This is a trend. Weird things suddenly not working in Firefox.”

So I am curious if anyone here has any insight into what is going on. I can easily imagine Mozilla losing their edge and becoming incompetent. But I can also imagine a competitor such as Google and/or Microsoft conspiring to make it impossible for them. And I definitely do not want to Google’s or Microsoft’s pawn.

#2

The youtube stuff is deliberate sabotage by Google. They’re always doing it.

Also, I use Ad Block Plus on Firefox 66 and it’s working ok. Weirdly though a quick google shows that lots of Add-ons have suddenly broken. If you can’t wait for that to be resolved, try switching to add block plus?

I’ve used Firefox since it was named Phoenix (and then Firebird), and I’ll keep using it until it’s no longer viable, no matter how often Google try to throw spanners in the works.

#3

Most add-ons are disabled right now, it’s quite a mess:

#4

Do you have ‘Do Not Track’ enabled? That’s my only ad blocker. No ads on Weather Underground (and still functional?).

#5

You should use uBlock, not Adblock Plus.
Ouch, this is the worst fallout of an expired cert that I can recall. Let me not update anything today… Can’t companies have some automated warning for this? I hear computers are really good at it.

#6

Well, you should use uBlock Origin, rather than uBlock ;)

But it’s a good point, actually. I use uBlock Origin on Firefox on my other computers and on Chrome, but the computer I’m on now is old and I haven’t paied that much attention to those things. I should switch to uBlock Origin… though I’ll wait for this storm to die down, first :)

#7

Check out Brave browser… it’s basically Chrome (build of Chromium, the open source stack behind Chrome) with built in ad blocking and no tracking. Free at the moment. I’ve been using it heavily for the past few months and it works well. It’s easy enough to activate scripts on various sites, when needed.

#8

How is Opera nowadays? I recently switched to Firefox from Chrome, I like it, but it has some rough spots, like this extension thing. (And gestures won’t work on my laptop’s trackpad which is driving me nuts.)

#9

Also, all Firefox extensions are failing at the moment because they let an intermediate certificate expire.

#10

Yeah, this was some real clownshoes shit from Mozilla.

Anyway, it should be fixed now if you restart your browser.

#11

I wondered why NoScript wasn’t working today.

Thanks for the heads-up.

#12

Moved to Hardware and Technical Stuff.

#13

Sorry! That is where I intended to post it.

#14

Not fixed for me, is there anything I need to do besides restart the browser?

Either way I’ve moved most everything over to Vivaldi, been using it on and off for a few months and I like the cut of it’s jib. All my firefox extensions work on it so I’m going to stick with it for now and see how it goes.

#15

You need to have “Allow Firefox to install and run studies” turned on in Privacy & Security to get the hotfix currently, and it may take a while to get the study.

#16

@NuclearWinter That worked, Thank you!

#17

Firefox has been crashing quite often lately. I don’t recall this happening before.

#18

Yes, the normandy studies thing needs to be on, and it can take up to 21600 seconds. You can change that in about:config if you don’t want to wait.

#19

The studies thing has been on all along for me, problem not resolving.

Also tried disabling signature enforcement. Still will not download ublock or load Adblocker.

UGH!

#20

Set app.normandy.run_interval_seconds to 1 then restart Fx. That should do it. Then set it back to 21600.