Frustration with Stardock and GalCiv2, Help

I know, I know, usually stardock is the savior of gaming. However…

The short of it is my computer died so I am reinstalling my old programs. I originally purchased the physical retail GalCiv2 Gold edition (original plus Dark Avatar) and installed it then registered it online. From that point onward I just used stardock.

So on my reinstall I just load up Stardock and it has my programs still tied to my account (good), but it says there is a problem with my Dark Avatar cd key (bad). Well, the gold copy only has 1 cd key. The same key that is registered to my GalCiv2. The same 1 key that is tied to DA in the registration screen. When I request my keys by email it lists GalCiv and the expansion a bunch of times and the same key tied to each.

What am I doing wrong? How can I get it to know I have a single key for the gold edition again?

I have tried emailing support but have not gotten a response yet so I thought some of the fans here might have an idea.

Thanks for the help.

How long has it been since you e-mailed Stardock? Usually it’ll take ~3 days for a CD-key issue. They’re pretty swamped with the impending release of Political Machine which is why you might not have gotten quicker help right now.

For now, I’d suggest un-installing the game and Stardock central, clear out the directories, and then just install Dark Avatar (the installer will grab the rest of what you need on its own). Then register just Dark Avatar which should validate the rest.

Otherwise you’ll need to wait for Stardock’s help.

It has been a day, I guess I will either uninstall and try again or wait. It is just frustrating.

I would guess that the Stardock forums would make more sense for this thread.

At times they forums are difficult to get into as they get exceptionally slow.

I find stardock forums, um wonky. For instance I took the advice and posted (theoretically) a cross post in the “Dark Avatar” forum. But the newest post is still from yesterday and I can only find my own post by clicking “my posts”.

edit: or just slow… there it is.

Chill out, buddy. Go play something else while you wait for this to get resolved.

Are you sure that you are in the right forum? Hey he wants to play that game… that means now, not tomorrow or next friday… ;)

Their forums are pretty wonky. I see that the latest posts on the Demigod forum don’t even appear on the ‘latest posts’ portion of the index.

They’ve gotta be absolutely giddy that the campaign season is still going the way it is, dang.

That’s pretty wonky. Drop me a PM and I’ll check it out.

You can also go to and type in your email address and it should send you all your serial #s.

There definately can be issues with Stardock. I recently reinstalled “Sins” on my new computer (my first Stardock game on this PC) and when it asked me for my username/password I couldn’t remember what I had used for the password so I asked for an email. At which point the system told me my email wasn’t valid. I eventually dug up the correct combo and everything worked, but why it didn’t recognize the email addy I don’t know.

Yea, the back end of SDC is getting long in the tooth. Impulse has a much more robust backend, only 3 weeks until that goes out!

Good job with Impulse, by the way. My only gripe is that it arbitrarily decided I couldn’t install Political Machine 2004 on Vista. Had to resort to SDC, and the game runs fine.