Geek Alert: Help Me Troubleshoot DVD Playback

In the past, I have used my PC extensively to playback DVDs but in the last 4 weeks or so I am having problems. Today I decided to troubleshoot, but I can’t seem to figure it out.

To play DVDs I use PowerDVD, which came with my DVD drive (an old Raite 8x read-only drive). Now when I try to use PowerDVD, I get choppy sound.

Here is what I have tried:

  1. Using the least demanding sound options in PowerDVD (stereo)
  2. Reinstalling Nvidea sound drivers for my Asus AN8XD motherboard (built in sound, NIC, controllers, etc)
  3. Reinstalling PowerDVD
  4. Double checking that sound works fine in the Nvidea control panel for sound (no fancy options for reverb, equalizer, etc. Ran through the setup wizard and sound is clear in both channels).
  5. Rolling back OS (didn’t succesfully complete… Oiy!)
  6. Playing DVD in Windows Media Player, which for some reason won’t play any DVDs because it says they’re from the wrong region code! I searched for this error on the Web and it mostly applies to people who have ripped DVDs to their HDD. I can’t imagine why it would suddenly start happening now. People dealing with bad rips/DRM issues also complian about choppy sound. I wonder if this could be the root of my problem? If so, I can’t imagine how to fx it.

Does it happen with VLC?

I uninstalled VLC. I can’t remember why. Maybe I’ll try reinstalling it. I remember being annoyed at how agressive it was about taking over as the default media player for all file types, but all the media players do that sort of thing.

So I reinstalled VLC (making sure to deselect the file type options). Great sound, but now I get choppy video.

LOL, if I use VLC for video and PowerDVD for sound and I’m golden! Thanks for the suggestion. I wonder how DVD playback got so messed up!

Well, I think VLC uses just their internal built in decoders. I remember one pc I built where I didn’t bother with the powerdvd or whatever lousy nero media player software came with the drive. That’s when I learned dvd decoding wasn’t built-in to XP. vlc saved my butt.

It’s probably a software (probably codec conflicts, so you can just install ffdshow or k-lite on top?) or hardware. You could probably download a ubuntu disc to rule out hardware.

Thanks, wisefoo!

I removed the drivers/software for my capture card, but that didn’t seem to help. I had ffdshow on board and just removed it to see if that might help, but it didn’t change anything. Very annoying! Not sure what to try next.

Maybe I’ll yank PowerDVD and try VLC by itself? I really thought the capture card was somehow interfering, but now I’m not sure what it might be.