Getting old games (e.g. Deus Ex) to run on new computers

So, let’s say I’m trying to get an old Unreal engine game to run on a new computer. Let’s say it’s something like Deus Ex, the GOTY edition patched up to v112fm.

It’s behaving really strangely on a Dual Core CPU with 2GBs of RAM and a GeForce 8800. Sometimes it goes superfast with the mouse jerking the view hither and yon uncontrollably, no matter what setting I use for mouse sensitivity. Other times it seems to control normally, but there’s a weird lag I think might be associated with sound. Firing a gun throws everything off, and doing the lockpicking in the tutorial takes forever, as does the scrolling text for dialog.

Anyone know of any tips for getting an old game like this to behave?


Why do you want to play a game you hated?

Did you try running it in compatibility mode? If I can play Wing Commander III from the Kilrathi Saga in Vista using that, you should definitely be able to play Deus Ex.

The Steam version works fine for me on Vista on pretty much the same hardware, though I don’t know if they did anything special to it.

When I tried the CD version under XP before, I did have to turn down the sound hardware acceleration before it would behave, though. I don’t recall it affecting lag, but if it does seem sound-related…

Go to your Deusex.ini file and set the game speed to about .3 or lower. It shouldn’t actually slow the game down any slower than intended, but it does have the effect of compensating for really fast computers.

I JUST dealt with this problem in Unreal Tournament at a LAN party. Some players were moving ridiculoulsy fast, and then getting held back by the server (in SP the game just ran as if some one had set the game speed way too high).

Alternatively try this:

If you were playing Deus Ex then I might suggest the fan texture pack - Link

Also select OpenGL and use this the render at the following page - Link

I’m glad to see that Tom is giving Deus Ex (my “best game ever”) a second chance.

Don’t forget that patch that takes the combat knife out of the game. I forgot its name now…

Try turning off/on sound acceleration as well.

Mmmm, now I want to install Deus Ex again. Good times had by all…

Geeze, he said “like Deus Ex.”

You also could try setting the CPU affinity. Dual-CPU’s may cause issues with older games.

Yeah, he probably needs help running Clive Barker’s Undying.

Deus Ex gets mentioned in QT3 so often that I just don’t bother uninstalling it anymore.

Does anyone know if there’s a way I can run Deus Ex at 1280x1024, without a huge UI scaled for 640x480?


I’m just surprised that people uninstall games instead of buying more HDDs.

Well, I have a $20 case that holds 500 CD/DVDs. Plus, 15 minutes of my time to install any game in my collection.

Plus, we can go the digital disribution route, where games are just waiting on a server for me, be it from Steam or GameTap.

Or, I can spend hundreds of dollars on more and more drives, plus, the 15-30 minutes of transfering data to the new drives, and installing them.

Oh yeah, I can see why people uninstall games.

It’s not so much uninstalling games, as it is reinstalling the OS on a formatted harddrive to clean up Windows, and then not bothering to reinstall the game.

I have a dual core Vista laptop and this is what generally works for me. It worked for Thief II and Anachronox, both of which I have recently installed.

Although I tend to find I need to modify the game executable to make sure it works using the tool downloadable at this site as there is no way I know of to make a game use only one core except after it runs otherwise.

So it turns out it was simply the dual core. Alt-tabbing out and setting the process to single core affinity fixed everything right up.

Mog, it’s for an article. And the Harvest Moon cow says ‘hi’ to everyone.


Be sure to follow the advice in the “Saint Paul - The Wrath of God” section.