Giveaway thread!

Thanks guys! Sounds like FO:76 may be my next game after I finish King Arthur : Knight’s Tale.

Hmm, do the Prime games not drop on the weekend or something? I’m not seeing them on Twitch.

Huh, yeah. Don’t see them either. Usually they’re right on the dot.

Not like I don’t have a couple hundred games to play already.

Yeah, I was clicking around and nothing. Tomorrow it is.

So here it is Monday and I still can’t find it. Anybody have a link?

Not out yet either.

They’re up now. Or at least some of them are. No Total Warhammer 2, Shadow of War, or Glass Masquerade. Yet.

Edit: Ok, TW2 and Glass Masquerade are there now. Still no Shadow of War.

TW2 is on EGS, which isn’t ideal as I have TW1 on Steam. Oh well, still a good free game!

And Fallout 76 is on the Windows Store…

I only see Horace, Hero’s Hour and Loom as Prime free games. Under the heading Free Games with Prime. Perhaps there are higher level Prime memberships? I should know how that works.

Huh. They’re all now showing for me under “Games, free with Prime”. You’re going all the way to the bottom of the page?

Fallout 76 being only through some shit dubious Microsoft window…is shit.

No clue if it is installing. Clear as mud.

NM, I see it now.

Keep getting an error message just trying to log in. So tomorrow it is.

oh wait, no, I also have it on EGS, I guess from some past giveaway. yay!

Now that I got in, my experience is the same. Was it ever installed for you?

Edit: I’m guessing it’s installing in a windows apps folder, since I do not have permission to access the fucking folder.

So the install button is greyed out. I guess I’ll be checking it now and then to see if it changes.

I just finished Glass Masquerade at the weekend, it’s a great game.

Ah darn, Glass Masquerade is a new game launcher I’ve never heard of. Oh well. I have to draw the line somewhere. I can’t keep forever getting more game launchers.

No clue. I clicked Install then went to bed. Now I can’t find it. Yeah, I also tried accessing C:/Program Files/WindowsApps and got YOU DON’T HAVE PERMISSION! Access denied! WTF this is MY computer!

What a terrible thing Microsoft.

Right click the folder, choose Properties. Go to the Security tab, click Advanced Settings. Change the owner from TrustedInstaller to administrator or you.