Goddamn Steam

Due to the release of Half Life 2 Ep 1, I loaded up Steam in hopes of buying it online instead of going outside and facing the giant ball of fire that our world orbits. When I try and buy it, I get a “Page Cannot be Displayed” IE looking error. When I try to purchase it via www.steampowered.com, I get the same error and it is trying to go to the site “steam://purchase/79”. Have any of you guys had this issue? If so, did you fix it?


PS I am not running anything like a personal firewall or an AV software. The only firewall I have is the one my router provides.

I get the same IE looking error.

I still haven’t tried HL2: Lost coast, so I tried downloading that instead, and I got the message that Steam servers were overloaded, and to try again some other time.

I suspect that’s why we’re getting the other error when we try to purchase Episode 1. It’ll get better when everybody and their grandma isn’t trying to get a hold of Episode 1.

So, overloaded servers on release days is the rule, i.e., just something to deal with in the digital distribution era?

Seems like the digital equivalent of 360 and SP3 shortages. Admittedly not as long, though.

Never mind overloaded servers, I can’t even start steam now that I haven’t got internet at home. Until a few weeks ago it would let me choose to start in offline mode but then close, I think saying something about an authentication problem. Now it just crashes.

LOL. Oh, sorry.

Steam totally barfed on my home gaming system today. “Error: Winsock: connection dropped.” This was a Windows hardcore error dialog.

Whatever, I’ve had the credit card auth problems since I tried to buy Rag Doll Kung Fu. Do I have time to fuck with their support department? No.

… at least, not until Oblivion gives up its fucking hammerlock grip on my gaming existence! I swear to god it’s getting so bad I’m taking weird roundabout overland routes just to clear every frigging cave I can find. Help me, aaaahhhhhhh

The content servers are not near overloaded.

The servers being full response is just the craptastic generic response steam generates when it isn’t sure why it can’t connect to the server or the session is having an issue. Admittedly we really need to get more granular about the error. Try rebooting or logging out and back in of your steam account.

Not sure about the page not found, do you have to setup port forwarding for games?


For you guys getting the page not found, did you move your steam install? The issue your pc can’t find your steam install.

To move your steam install correctly, Check Here

“The Steam servers are currently too busy to handle your request.
Please try again in a few minutes”

That’s the error I get EVERY time I try on my home system.

Update: Apparently some problem was related to that file…I deleted it and it started doing updates again. Thanks chet!

Did you try logging out and logging back in? It may sound counter-intuitive, but give it a shot.

As you can see above, you already got my problem…but what’s with having to do that on a regular basis for new updates? You guys going to fix that? :D

It only happens (I believe) when you have a new key/game installed and it is a rare occurence. But yeah it is a known bug that will be fixed.


I tried again as well, after deleting the file mentioned in the link above.

Now I am successfully downloading HL: Lost Coast at an absolutely stellar speed.

Thanks Chet!

I’m still getting a “Page Not Found” error when I try to purchase Episode 1 though. I’ve tried logging out, and logging back in.

What I had done wasn’t that I had moved my Steam install. Steam was installed on my non-main hard drive, which used to be D. But when I rearranged hard drives recently on my machine, it became my E drive, and I also reformatted my Windows XP hard disk, so all my registry entries on C: are gone.

Maybe the only way for me to purchase Episode 1 through Steam is to uninstall and reinstall Steam?

I have yet to get Steam to actually install on my PC. I’ve opened all the requested ports in my router but still get a “can’t load Steam.dll” error from the updater.

It may be that I have a funky set up. I use an external wireless adapter to hook into the ethernet on my PC rather than a wireless card. Still, other things that require ports (like MySQL) seem to work fine.

Oh well; my urge to play Half-Life is not stronger than my reluctance to rewire my house. I’m uncertain that if I get a physical copy it will be able to run/patch/etc. and just don’t have time to deal with it.