Going insane because of DVD-Rom drive

I’m tired as hell, I’ve been working on this for a couple hours now, and I’m getting nowhere:

My main 48x CD-ROM drive died a few weeks ago, so I decided to replace it with a DVD-ROM drive, so I could watch movies in a window while doing other computer work. I ordered a 16x Lite-On DVD-ROM off of Newegg.com based on some good reviews and specs, and received it in about 4 days.

So I pull out my old CD-ROM drive, put in the DVD-ROM, connect everything up, and turn on my computer. My system BIOS auto-detects the new drive and identifies it as a DVD drive, WinXP sees it as a DVD drive.

BUT, the drive doesn’t recognize/play DVDs. I set it as region 1 (USA), and it can view and play CDs, but every time I put a DVD movie in the drive, it either: a) spools up, stops, spools up, stops, etc, forever; b) spools up, stops, and then refuses to respond at all, including the eject button; or c) locks up my computer when I try playing a DVD using PowerDVD after about 10 seconds.

Now, my computer is using 4 IDE devices: both hard drives on IDE 0 and the DVD-ROM as master and CD-RW as slave on IDE 1. Up until a few weeks ago, with my normal CD-ROM drive a master on IDE 1, everything worked fine. Then my comp just stopped recognizing CDs in that main CD-ROM drive, and then the drive would fail to read discs - it would spool up, stop, spool up, stop, in an endless cycle.

Thinking my DVD drive problem may be related to bad cables, I replaced the IDE cable that connects my optical drives, and I also replaced the power cables connecting them. Still no luck.

Please, anyone out there have any insight into this problem? I’ve been working on it since midnight - it’s now quarter to three, seriously, and I’m practically passing out at my keyboard but this problem is annoying me so much I have to at least post this.

Sounds like the controller might be wonky. Did you do anything else to the system?

I had something similar happen with my controller for IDE1 (there’s a thread here from a few months back). It seemed like it just suddenly decided it wouldn’t work with my DVD drive and my CD-RW. As it turns out, I had added a second NIC to the machine and it created a conflict with IDE1 that was only noticable when I put a disk in the DVD drive (machine would lock up). It was hard to track down because I had put the NIC in, then didn’t use the DVD drive for a few weeks, so I didn’t make a connection. Long way of saying you really have to think about what else might have changed, now that the obvious doesnt’ work.

Or the DVD Drive just might be bad. RMA that sumbitch monday if you don’t figure something out by then. If it can read CDs but not DVDs I’d assume it isn’t something simple, something that should be a problem whatever you try to read. It probably has something to do with the laser or lens or something keeping it from switching to the proper frequency to read DVD media.

What you do, Balut, is take the DVD drive to a friend’s house and install it there. If it works in his computer, but not yours, you know that you have some other problem with your computer system.

Alternatively, take the DVD drive out of his computer and put it in yours. If it works, then you know there is something screwy with you DVD drive.

This is the way of computer troubleshooting: pair a single suspect component with known good components.

Just another bit of info I just discovered - the DVD drive won’t play back audio-CDs either. When an audio-CD is in, it locks up whatever program I use for playback.

So far it’s:

  1. CD-ROM (data) = readable, the drive seems to settle in about 2 seconds
  2. DVD-movie = unreadable, the drive spools up/stops in an endless cycle
  3. CD-audio = readable, but unplayable - it takes a long time to detect the audio CD, but locks up when trying to play it back

Any hints?

There’s a small chance it’s the bus transfer speed (occasionally a problem with VIA chipsets). Otherwise, it sounds like it’s probably the drive. I don’t suppose the manufacturer has new drivers, etc.? My Toshiba drive used to give me all sorts of trouble.

  • Alan

Maybe it’s a tumor.

  1. It’s not a toom-ah.

  2. I checked Lite-On’s website and they don’t have any DVD-Rom drivers.


What operating system? If a Win9x/Me version, make sure you have DMA enabled for the DVD-ROM drive.

Does sound like a hardware problem, though. Best bet would be to try it in another system if you have a willing friend…

Well, I pulled the DVD drive out to try it out on a friend’s computer, when I noticed something. When I’m holding the drive and move it around, an audible rattling is heard from inside the drive, like some parts fell loose inside. This pretty much made my decision for me - I did an online RMA request and shipped it back to the vendor for a replacement.

Now I’m a bit curious as to what loose/missing part caused the drive to read CD-Roms but not DVDs or CD-audio discs.

Maybe it was a casino token? (I was going to post a link, but the stupid computer tricks site is down for maintenance.)

  • Alan