HD upgrade slows things down?

On my main computer I’ve had 2 200GB hard drives in a RAID 0 array for the past 4 years. I’ve outgrown the 400GB thanks to Steam, and I’ve always been antsy about the RAID 0, because if one of those drives go, I’m really fucked.

So over the Christmas break, I picked up a Western Digital Caviar Green WD15EARS 1.5TB 64MB Cache SATA 3.0Gb/s on Newegg and finally got around to installing it this week.

After some wrestling with Microsoft, I’ve gotten Win7 32 on it and working, and have moved all my data over, and I’m now reinstalling everything.

But man, is this thing slow.

I will get long pauses even if I’m just in Firefox reading Qt3. It’s not writing to disk, it’s like it’s deciding where to write to the disk.

I have an M2N-SLI Deluxe mobo, and I thought the nForce drivers from nVidia were the problem (or the lack of those drivers with just a straight Win7 installation). I got the drivers and no change.

One curious thing is that under “Devices and Printers” the hard drive shows up as a device and it says it has a problem. The problem is that the PCI drivers aren’t installed. When I tell it to go find the drivers, it can’t. It won’t even find them while looking online. I’ve been hesitant to disable the hard drive in the devices section, because then… well the hard drive might be disabled. The thing is, I just checked on this laptop and the hard drive doesn’t show up as a device. And why does it need PCI drivers when it’s a SATA drive?

So this seems like it’s some sort of driver conflict or some weird Win7 thing where it’s trying to access the hard drive one way, timing out, then accessing it the right way or something.

Any thoughts? I think I’m going to disable the device tonight when I get home. It seems to me the new hard drive should’ve made things faster again because it has plenty of room for virtual memory again, not slowed things down.

Oh, and the CPU is an AMD Athlon 6000+ with 2GB of memory. It could really handle everything I threw at it until this upgrade.

WD Green drives are slow by design (low power, quiet), but not slow enough to cause the sorts of issues you’re seeing. I’ve run them under both Win 7 and Linux and never had these sorts of serious speed/hang issues.

Presumably your chipset and/or driver situation (or maybe choice of plugin ports?) is to blame … it sounds like the system belives the drive is a removable device that could be pulled at any time and is probably running it in “Quick Removal” mode which disables write caching to avoid data loss that might occur if you pull the device out after a file has been written but before it has been flushed. This is a huge performance killer and should never be used for internal system drives.

You may want to go to Control Panel/Device manager, right click the drive in question, choose Properties and look at the Policies tab to see what options you get. For internal drives you should see options for “Write-caching policy”. Make sure you check the box to Enable write caching on the device if it isn’t on. If instead of “Write-caching policy” it says “Removal policy” on that tab then the system does believe the drive is external (it isn’t on an eSATA port, is it?). In that case you can still switch it over from “Quick removal” to “Better performance” (assuming it is on Quick Removal now) and that should help your performance, but you really should try to figure out why Windows thinks the internal drive is an external one if that is that is actually the problem.

I do have a 400GB hard drive hooked up to the external SATA port, but that one is registering as internal. I’ll try unhooking it tonight when I get home.

CCZ is right in that Green drives are slow, but also that you shouldn’t be experiencing the problems you’ve had.

It looks as if that motherboard may have two different SATA controllers. a JMicron and an Nvidia controller. Maybe just try changing the SATA port your drive is plugged in to use the other controller? The manual should indicate which ports correspond to which controller.

You may need to then go into BIOS and change the boot order to make certain the 1.5TB drive remains your primary boot drive.

Okay, here’s the kicker. Part of my initial installation woes was that I have an upgrade version of Win7, so a clean install of Win7 cannot be activated. So I called Microsoft’s Indian call center and was told that “essential parts of the operating system just are not present on the drive.”

At that point I decided it would be quicker to reinstall XP, and do the upgrade than argue.

That’s what I did. And after wrestling with getting XP to work and connected to the internet, Win7 told me that I could not upgrade from XP to Win7 and I would have to do a Custom Install, which is what I did in the first place. So I screamed real loud, reformatted the drive, and did a custom install. This time when I put in my activation code in, things just kept going. Yay! Whatever bit we needed was flipped.

Or something.

So while checking around tonight I see that I have 27 days left before my software MUST be activated.


It didn’t just work, it just didn’t bother to tell me that the activation code didn’t work.

So are the pauses Microsoft anti-piracy douchebaggery?

I guess I’m going to call Microsoft India again and escalate this time.

I doubt the performance issues have anything to do with MS DRM.

Windows 7 does an ‘image’ install. The part about “essential parts of the operating system just are not present on the drive.” is total BS.

As for activation, did you try to activate? Accepting the code is the first step, you still have to run the Activation process. If you try to activate over the Internet and it fails, there’s a workaround, because you actually can install Win 7 upgrade to a clean drive even though you’re supposed to have an activated XP or Vista first. It’s unsupported but it works fine, and when you’re done it’s the same as having installed from the ‘full’ version. Just to re-emphasize: there’s NOTHING missing from an upgrade install compared to a full install. The only difference is the activation process, which you can do an end run on. Just follow the one of the three workarounds here: http://www.winsupersite.com/article/windows-7/clean-install-windows-7-with-upgrade-media.aspx


The regedit activation worked.

The pauses are gone as far as I can tell. I still have the drive showing up as a device that isn’t working, but it also shows up as an internal hard drive. Unplugging the eSATA drive might’ve done it, though.

I also tried to install drivers for my HP printer and for some reason it would finish but just not take. As soon as I activated it installed no problem.

I don’t know, it could be a bunch of coincidences, or it could be DRM douchebaggery.