Heads UP: Civ IV 1.52 patch. Now with memory optimizations

I have had very little slow down and maybe one crash, but thought some of you may still be having “the problems”.

Man, just in time! I’ve been having tremendous fun with the game but the stutters and slow down have been very nasty in my current game. I’m on a large map and every five minutes or so the game processing slows to a crawl. The Wonder videos have not worked well at all either but that doesn’t mpact gameplay. I have an older machine but a decent video card and 1G of memory. Everything is nice until the late game.

Heh, now I can try this patch out and get back to crushing the Aztecs.


Hmmmm haven’t tried it yet but I’m wondering if the memory optimization is as good or better than that fan made patch (Harkonnen).

Yeah, the patch notes even take a little shot at that patch (indirectly, though it’s pretty obvious). I suppose the kind thing (and quite plausible) is to say they had to do it for legal reasons.

Played a couple hours with the patch. Absolutely love it. The game is smoother and much more responsive.

Even gayer for Soren Johnson now (and the rest of the Civ4 team. Don’t worry, I didn’t forget about you <3).

THe patch either made the AI better or me dumber. My strategery is failing me.

Oh noes! This is then doubly bad for those of us who sucked before the patch! :oops:

Oh noes! This is then doubly bad for those of us who sucked before the patch! :oops:[/quote]

I have found the AI to be refreshingly challenging. Not as smart as a human of course but I like how it at least tries to be creative. Last night I was pounding on the Aztecs. I had their capital surrounded and my tanks and bombers were just making a mess of their rifleman and knights. I thought the AI was just going to sit there until I whittled his forces away. But suddenly the AI makes a desparate attack flinging his knights against my tanks. They were total kamikaze attacks but eventually one of my tanks were brought down. Of course I had a shitload of new ones coming but it was cool that the AI was at least trying to fight back instead of just sitting behind his walls and getting beat down.

What I found helped me in the current game is using Elizabeth. The financial trait really starts to kick in and if you can keep ahead of everyone tech wise it makes the game a lot easier (at least on Noble). Only the Aztecs were stupid enough to bother me. The other key thing is to make sure to be first with colonization. Depending on the map type you are playing, there always seems to be a lot of terrain that is not initially accessible to AIs or humans. The barbarians build up their own kingdoms but there is still a lot of free space. I have found that whoever builds up this space first is usually the winner of the game.

Sometimes you can colonize with the galleys but most likely you will need galleons. I’m thinking that this is so important that it probably should be the highest priority. In my current game I wiped out the barbarian louts and took over 95% of the free territory. By the time the AI arrived to colonize, there was hardly anything left. They each have a small foothold but my growing cities leave them with no space to develop.

My comments relate to the earth like maps with seven or eight civs standard size.


I really like some of the changes they made in the patch. One of the big ones (although seemingly small) is that the trading screen now lists the resources being offered with a, for example, “(1 of 4)” description beside it. I used to always have to check to see how many of a resource I had before I could accept/reject a trade (which meant I had to negotiate first), but now I can make a decision immediately. Love that. [Edit] Also want to add that I’m pleased with the changes made to the info screen at the end of a game. The line graphs are much easier to read than the previous incarnation.

Still haven’t won a game on Noble, and Tokugawa is slaughtering me in my current game, but I have to say I’ve never been so bad at playing a game yet kept coming back for more like I do with Civ4. That’s definitely the mark of a great game.

I got the impression that the AI is more aggressive now, at least for those leaders who tend to be aggressive anyway.

The various small interface improvements are definitely welcome, as is the new Civilopedia interface… although the alphabetic sorting should go in columns downward, not in rows across. Harrumph!

Also, I’ve finally found a way to fix the video playback!

The various Bink performance setting in the ini file had no effect at all, other than making the videos uglier. That was to be expected since I’m running on a P4 @ 3.2 GHz with 2 GB RAM and a GeForce 6600 GT… it’s not like that machine is somehow to slow to play back a video in a small window.

What did have an effect was setting the CPU affinity of the Civ4 process (or rather the GameJackal process in which I’m running Civ4 to avoid the CD check) to just one of my two virtual CPUs. My Pentium 4 has hyperthreading, and Civ4 apparently has some serious race conditions in video playback on such a system, or at least on my system.

After a long playtime the videos eventually still lock up altogether – that’s to say, I get a frozen frame while the sound keeps playing. But up to that point, at least, videos now play smoothly.

I’ve also changed some ini options which seemed to improve playback slightly:

BinkNoSkip = 0 ; CHANGED, was 1
DynamicAnimPaging = 0 ; CHANGED, was 1
D3D9Query = 1 ; CHANGED, was 0

You can set the CPU affinity of a process with the free Process Explorer utility by SysInternals. Unfortunately, it’s not possible to set the CPU affinity for an executable, so Civ4 must be started before you can use PE. Another reason to use GameJackal because Civ4 inherits the affinity of the GJ process!

Could anyone else who’s having video playback trouble please try this out and let us know what happened? Also, post if you have an MT or dual-core CPU and you don’t have these issues, or if you have a plain old single CPU and do have them. If it’s really a hyperthreading issue Firaxis might finally be able to fix it in the next patch.

Apparantly, according to CivFanatics, the latest GeForce drivers include a fix for Civ 4, but it relates to water textures rather than the Wonder videos.

I have been playing this game entirely too much. Live multiplayer is fun too (the pace is too slow for PBEM tho, the Q23 game we tried died a merciful death around 3000BC I think).

This did some good things for me. Wonder movies don’t stutter anymore, though victory movies still do. I’ve got all eye candy cranked up and even in the late game the performance is smooth. Still get a hitch if you trade for a world map that reveals lots to you.

Here’s something that’s new, I think. Check out the forehead:

Also, a request if Soren reads this. I played a game on Chieftan for some easy expansion to test the game’s performance, and also because I was tired of losing all the time. I ended up with a Domination victory and getting rated Augustus Caesar. I don’t think you ought to be able to do that playing on Chieftan.

I’ve noticed a few random graphical anomolies, like flying polygons, and the teeth being rendered in front of the lips while the leaders load (really creepy). Other than that, it seems good.

Yes, it’s in the release notes. Ironically. I didn’t get the map graphics corruption bug since the last driver release…

I just found that deleting all files in the following folder and then restarting the game also causes wonder movies to play smoothly:

C:\Documents and Settings&lt;your name>\Application Data\My Games\Civilization\cache

There was a post on Apolyton claiming that deleting these files would reset an internal anti-aliasing setting that caused movie stuttering. I don’t know about that but this simple action seems to have the same effect on my system as the more convoluted CPU affinity setting I described above. Movies now play smoothly, up to a certain point where they simply lock up.

Ooh! This latest patch restored the Civ2 style power graph. Finally! The Civ3 style relative power graph was damn hard to read.


Yeah, that’s what I was referring to earlier. I spend a lot of time on that info screen set now, zooming in on the various turn ranges to get more detail for each of the categories. It’s how I now know just how much more culture I have than the other civs and when it starts picking up. The other civs really don’t build culture much until they are done with everything else, it seems.

I still get a kick out of the Xfire installation prompt during this patch (as well as the prior patch). Your options are to “Yes, install Xfire.” or “No, I don’t want to play with my friends online.”

They should have reworded that second option to read “No, I’m a freaking shutin who flings virtual poo at any who should have the audacity to send me a PM. Of COURSE, I don’t want to play with these …people… online.”

Or, more accurately, “No, I abhor your corporate ‘strategic alliances’ and recognise that Civ is best played alone, naked, with cognac and a fine cuban cigar.”