Help! Can't access router setup screen from one computer

OK - I’m in a hotel room, my home for the next couple of months while we’re in transition to my new job in KC, MO, while my wife and kids stay behind to sell the house. And of course, our first night separated and she has an internet emergency!

Problem is simple but I can’t figure it out. We have a filter on our D-Link router that turns the internet access on or off for my 15 year old daughter’s computer (to keep her from staying up all night IMing.) My wife knows how to simply click the Router link on her toolbar (Firefox) and then which button to click to make the change. So daughter has homework, she clicks on the link (which goes to http://192.168.0.1/ ) and nothing happens except a “this page contains no data.” Oops. She calls me, I have her type it directly into the address bar, same results. She can get to Google, other pages, just not the router. She has wireless access - she can email, browse, etc. - but when she tries to access the router setup page she just gets that “page contains no data” message. I had her check and make sure she’s connected to our router instead of a neighbors, and she is. What is odd is that when she used my older daughter’s notebook, and enters http://192.168.0.1/ it works fine. Used that to get the younger daughter running for her history paper. But it will not work on my wifes notebook. I had her check the properties of the link (fine,) directly enter the address in the address bar, and even close Firefox and open Internet Explorer, and she gets the same “page contains no data” message.

This worked fine on her computer when we left Friday, her computer has been home and turned off since then, and she can apparently access the internet no problem.

Help! Why would the router out of the blue (D-Link DI-624) only keep her notebook from accessing that page? And let her access the rest of the internet, mail, etc.? In Firefox and IE? Very frustrating trying to fix it from a hotel room 550 miles away.

Unplug the router and filter, plug them back in.

I’ve never used a filter, but if Alex’s suggestion doesn’t work, you might also have your wife check the router from the notebook that does have access and make sure that the other one also has access. I’m not sure why it wouldn’t, but it’s worth checking. Most likely, the soft reset Alex is suggesting will help though.

Tried unplugging and plugging in the router (and the cable modem,) no joy. Filter is turned off. And she’s able to access the Internet, etc. via the router. Just not the router setup page, aka 192.168.0.1. Yet other computers in the house can access it.

Ugh

“Page contains no data” is just really, really odd. It points to a browser problems.

  1. Try a different browser
  2. Try a CTRL-F5 (dump cache, reload)

Try accessing the page from another browser (IE in this case). Or Opera if you swing that way. Also-- can she ping it? I can ping my router at 192.168.0.1.

Browser problem. If scripting is disabled in IE it might not load the page. It sounds like a security setting. I’d also check for Firewall settings that might interfere. It’s definitely the Laptop from the sounds of it.

Have her try to access the router from a non wireless connection. Most routers have an option to disable wireless access to the router admin.

She tried going from Firefox to IE (which she never uses - I had to talk her through finding it over the phone) and it gave the same results. IE is just like it comes from the factory on her system, since she’s never used it in the 1.5 years she’s had the notebook.

What is really odd: she can’t access it from Firefox or IE on her notebook (and she uses that page pretty frequently) yet my daughter’s notebook can access it just as expected. And the message is not “page not found” or such - it’s “page contains no data.”

Very frustrating trying to fix/diagnose this on the phone! :( Thanks for the ideas.

Do you have some IP or mac filtering set up on the router that disallows access from anyone not on the whitelist? Maybe she was dynamically reassigned a new IP that falls outside of allowed parameters.

PS - hard reset the router and reconfigure it from scratch. Normally this means to press and hold the reset button for 10 seconds.

I do have a filter that only allows certain MACs access (that’s how I filter out my youngest daughter when I need to cut her off) but that is turned off. Also - my wife CAN access the internet through the router, no problem (email, web, etc.) She just gets this “pages contains no data” error when she tries to access the router’s setup pages, i.e. 192.168.0.1. Which other computers in the house can access with no problem, and which she has always been able to access in the past. And she has the problem with both IE and Firefox. Very puzzling.

Do you have a secure password on the router? Maybe one of your kids got wise to it and blocked your wife from getting in. You can do that on some routers, I think.

Also, if it’s a combo wireless/wired router, you might have her try plugging in via cable and see if she can get in that way instead.

you might be approaching it the wrong way. sounds like something browser-affecting on this computer alone is preventing the admin webpages of the router.

localhost file blocking 192.168.0.1 or something? then again, that would probably break your wife’s internets altogether.

try this at the command line:

telnet 192.168.0.1 80
GET \

you should get some kind of response… auth is required, but you should get HTTP headers at least.

If you don’t get a response, it’s 100% a network problem, and has nothing to do with the OS/browser.