Help: IDE Controller 101

Ok, I have been messing with a hardware problem for the entire weekend and I am ready to ask for help.

I am trying to move my CD burner into my fast machine. The machine already has a hard disk and a DVD drive. I have the hard disk on the primary controller by itself, the DVD on the secondary controller by itself. I want to put the burner on the same controller as the DVD. I can’t do it!

I have tried everything I can think. Most often the problem appears before it even posts and I get a halt error with a message for each drive saying something like, “ATAPI device not recognized.” If I put either one on the cable by itself, it works. I have tried most every different permutation of Master|Slave|Cable Select. Occasoinally it will work one time, but when I reboot it misbehaves again.

I think conventional wisdom is that a CD Rom should never go on the same controller as your hard disk because it slows performance down, so I have not even attempted to put it on the primary controller.

Has anyone seen anything like this and can offer advice? Is the conventional wisdom about CD roms and hard disks true? If so how bad a performance hit are we talking?

Thanks for your help!

I’m pretty sure…yep…I’ve got a CD drive and a CD-RW on the same cable, so I can’t really comment about the hit to hard drive performance. I don’t think I’ve ever seen a noticable decrease in performance when a CD-RW has been coupled with a hard drive, but I don’t know if I’ve really used that configuration often enough or for enough prolonged periods of time to be a fair judge of such things.

Really strange that you’re having such problems with that, though. Are they the same brand?

It sure sounds like you’ve tried everything else, so if I were you, I’d just hook it up with the hard drive and see if you can tell a difference, and, if so, how bad the difference is.

I’d love to be able to spout off a better answer, but this one’s got me baffled.

If the DVD drive is jumpered as Master you have to jumper the CD-R as slave. Other than that I’m not sure what you problem could be.

And if they’re both set to cable select, they should sort it out between themselves. Sounds like you’ve tried every possible combination there, though, right?

Did you try it with another cable?

I have had cables do some really goofy things when acting up.

Also, did you try it with the harddrive just to see if they could both be slaves? and then switch one to master and try it on the other cable?

Chet

Cable is a good idea. Assuming your jumpering (I created a verb!) is correct, try a different known good cable.

Late last night I tried to set the DVD on the cable by itself and it came back with the same damn error. Now I believe the controller itself has gone bad.

I just purchased this motherboard about a month ago. I am bummed. I should have gone Intel with an ASUS motherboard last year when I first put this together. :(

Edit: yep, I tried a different cable. Also tried setting one as master, the other as slave, and then reversing, and then using cable select on both. I know the burner, at least, can be a slave, because that’s how it was in the other machine.

Tim,

What model motherboard are you using? Do you know that the IDE controller chipset is?

If your motherboard is dead, it might be easier to go out and buy a PCI IDE controller rather than replace the motherboard (even if it’s under warranty, since you’ll probably get shafted with shipping!) Promise Technology makes great IDE controllers that, for the ultra66 versions, you can find for about $20.

The conventional wisdom about the CDROM and hard drive is mostly right. However, it really depends on what you’re going to use it for. For example, if you’re generally going to be making copies of CDs , you should put the CDRW on one controller and the DVD (which serves as your CD reader) on the other. So I’d put the HD and CDRW on one controller and the DVD on the other; you won’t often be writing from the HD to the CDRW unless you’re burning images or copying stuff onto CDs. Okay, that made almost no sense – whatever device you intend to write FROM (the hard disk, DVD drive, etc.) should be on the other controller from your CDRW.

asjunk,

Yes, I have been thinking about purchasing a controller, but I am still undecided.

It would save me the effort of having to rip the mobo out. And if I got the promise card, I could do have the dvd, burner and hdd all as master of their own controller, so I could write from disk or dvd to cd/rw. That in itself might be reason enough to make the purchase.

The only reason I am hesitant is that it seems like bad karma to keep a brand new motherboard with a bad controller. Newegg has already given me an RMA number. I also had planned to sell this board, memory, and cpu to my neighbors in the fall, so I could get out of it without too much pain and go intel.

I have only built four machines: 3 intels, 1 amd. I have had nothing but problems with my AMD… Crap, I am gong to stop. I can feel an AMD sux thread coming on. :)

It is an ECS K7S5A. I am not sure what controller comes with it, but it looks like this in Device Manager

You sure the DVD works? Cause it’s starting to sound like it’s the problem. Test the CDR and the hard drive on the second channel of the IDE controller before sending the mobo back to try and further isolate the problem. Maybe a bios update, updated IDE drivers from SIS, or a firmware upgrade on the DVD or CDR could help.

I hooked up the DVD as a slave on the primary controller (the hard drive is the master) and it works fine. I believe the cd/rw would work, too, but I have not tried it yet. Before I actually pull the board, I may try the disk and dvd on the secondary controller just to see what happens. I am pretty sure it’s the controller, but not 100% positive.

Occasionally when the DVD was hooked up to the secondary controller and I would turn it on, it would emit a loud whirring noise for a few seconds before failing to function. There was no CD in it. Who knows what the heck that’s about.

I know this board has the latest bios because I just bought it a few weeks ago and checked. To be honest, I have no idea how to go about updating the firmware for a DVD or CD/RW.

I really believe this is a one off deal for this ECS part. Every thing I’ve read about them indicates this is a stable, quality product.

This is just God telling me not to own an AMD. :)

On the contrary – it’s God telling you not to go with that motherboard! The CPU is probably fine.

A couple things – I’ve found a whole series of threads on the Internet about this board (see http://www.google.com/search?hl=en&lr=&ie=ISO-8859-1&q=K7S5A+ide+problem), and there seem to a be a lot of people who are having/have had problems with the board.

One quick question – do you still have power to both drives when they’re connected to the secondary IDE channel? To test, try using the eject button on the drive that’s hooked into the secondary. Some people have reported weird power issues with the drives.

Also, just as general background, swap out the IDE cables and test that – could be a bad IDE cable. Unlikely, but hey, if it’s a $3 solution…

I would completely agree with you about not hanging on to a bum board, particularly if you’re going to give it to a friend (an in-law would be another issue entirely…)

It’s also possible you should update the BIOS again – try re-flashing it. It’s available from http://www.ecs.com.tw/download/k7s5a.htm.

Also try my last ditch fix that worked twice. Go into your bios setup, first make sure the secondary controller is active. Then try disabling USB. For some reason, USB really causes conflicts with certain motherboards. I found it easier to disable usb and work backwards, then trying to get something to work with USB running.

Chet

As for as ECS is concerned, there were quite a few people who had troubles with their IDE ports because they installed the ECS driver and it was buggy. Going with the default Microsoft drivers often proved to be just fine. A ton of threads on ECS message boards were generated, detailing how to fix/workaround the problem. I have no idea if ECS has posted anything new, I’ve since stuck with the default MS drivers.

You might have some luck here and reading up on the FAQ links posted at the top:

http://www.ocworkbench.com/ocwbcgi/ultimatebb.cgi?ubb=forum&f=37

This all being said, have you flashed your motherboard to the latest ECS BIOS? If not, you might want to think about doing that. Conventional wisdom says never flash needlessly, but you’ve got a problem and a RMA, so might as well. (I flashed mine and it fixed a minor problem I was having, but I can’t recall now what trouble I was having)

The K7S5A is a great board…if you don’t innitially get a lemon. I’ve put together several machines now this board (my wife and friends, etc.), but two of the boards I originally received were dead on arrival.

And then there’s just the fickle nature of some IDE devices. Although it’s looking like the controller is giving you a hard time (again, try a different driver and/or flash the BIOS before reaching that conclusion), some IDE drivers just won’t play nice with each other. But I haven’t seen this happen for some time now. I’ve had drives refuse to be slaves to other brands of drives, etc. Only going through the myriad of combinations would yield any sort of success, so hoping to isolate harddrives from CDROMs back then was a luxury and not necessarily an option.

I wrapped that puppy up and sent it off this morning. I did have the latest bios update, but I didn’t get a chance to try flasing it over again or the USB thing. If I hadn’t been so quick to yank it, I would have tried both of those. I did try different cables. As fat as the power thing goes, sometimes I got power but other times I didn’t. It was very weird. I hope the next one goes in without any problems. Thanks for all the input guys. I apprecaite it.