Help me delete $WINDOWS ~BT

My dad’s PC has a 120GB HD which is about what he needs. I saw today that 18 are occupied by $WINDOWS ~BT which to the best of my knowledge is a renmant from upgrading the from 8 to 10 that was done a couple of years ago or more.

I really want to get rid of it. I tried disk cleanup which failed the first time, and now it won’t detect this folder at all. I can’t do it manually from file expolerer - I get a message saying I need builtin permission.

I found this command online:

takeown /F C:$Windows.~BT* /R /A
icacls C:$Windows.~BT*.* /T /grant administrators:F
rmdir /S /Q C:$Windows.~BT\

But that gets rejected as well: “Access is denied”.

Any ideas?

Try it from a linux bootdisk?

Can’t you just get the windows 10 install on a thumb drive, get him to move all his important files to an external hd or thumb drive, and then run the reinstall from a fresh wiped HD?

That is my only thought.

Just to make sure, you did run the command line as an administrator right?

Also try rebooting if you haven’t already to make sure disk cleanup, which failed, isn’t still running and holding a lock on the folder.

And finally go here and try this method to take ownership. It should work and allow you to delete it from explorer.
https://www.laptopmag.com/articles/take-ownership-folder-windows-10-using-file-explorer

Yeah, that’s my thought, too. It’s more work, but that’s an old installation, and god knows what other cruft could be lurking.

Are you logged in as admin?

I think it’s mentioned above but you have to run the command prompt terminal as an administrator. Search for “cmd” then right click and choose “Run as Administrator”

My link for Windows.old should work for Windows.Bt as well without resorting to command-line dark arts.

I am running everything as admin without success. Seems like the folder got tightly blocked behind the permission wall. I tried to tinker with permissions but couldn’t figure it out even looking at how-to guides. It doesn’t help that the permission screens is one of the worst designed and confusing piece of UX ever conceived.

Anyway I found a tool that changed the permissions on the folder, and that allowed me to delete about half of it’s contents, however the other half is again blocked from deletion, this time because active services are supposedly using the files (eyes rolling emoji here).

I’m really tempted to go with the nuke option, but I’m leaving this evening and I don’t want to end up not finishing this and leaving my dad without a working PC.

Download and install macrium reflect free. Make a winpe (pre boot environment) rescue usb with it. Boot into that winpe, use its file explorer functionality to delete the folder.

If you have a Windows boot/recovery CD then you can use the command line option there to delete it, as I don’t think it enforces permissions in anyway.

If you don’t care about the folder still existing and just want to reclaim the space, you can run robocopy against it and an empty folder with the mirror command switch.

The link I posted should work, no tool necessary, if you go slowly through it. Yes, it’s an amazingly terrible UI. You are basically working through years of cruft as microsoft over time went from no permissions to a very complicated ACL system meant to handle anything and everything.

*Edit - One change I would make to their instructions is to make sure ‘Replace all child permissions…’ is checked everytime. It doesn’t hurt in this case and may catch edge cases that are tripping you up.

Just to give some context the steps break down to 1) Taking ownership of the folder so you can make changes then 2) Adding full control so you can delete it yourself and then make sure those changes propagate through the entire folder.

Using the Windows built-in admin account might be necessary. I think it’s usually disabled.

I would suggest a Linux boot disk, but I don’t feel confident navigating the file system in Linux either.

Dumb question: Was Disk Cleanup run as administrator also? It can’t / won’t delete some files if not.

Diego

If you don’t run it as admin there’s a button to switch to the system/admin mode

Forgot about that, good point.