Help me install windows 7

I’m having some really bizarre issues trying to install windows 7. Background

I was running a dual boot Vista/XP machine. A virus totally tanked my XP install, and my Vista install had been problematic from day 1. So I decided, fuck it, time to buy a new drive, do a fresh install and try out Windows 7.

I bought a Hitachi SATA drive, and plugged it in, put in my Windows 7 disk and booted up. Now first of all, the boot program runs at the speed of a moose fart. It is seriously slow. It takes 3-5 minutes for the first page to show up (language selection) and an additional 3-5 minutes between each step until:

I get to the drive selection, I select my brand new hard-drive, it begins Copying Files then moves on to Extracting Files

It will reach anywhere between 25-40% of that process before I get a blue screen of death. I have tried this 6 times now to be sure. I really have no idea what to do, I find this problem totally befuddling.
I’m running an ASRock board with an AMD chipset. I tried disabling the old drives (i am going to move data from them, but nothing else).

When I googled this issue, I few people mentioned this problem, but quickly solved it by disabling EIST which is an Intel specific feature.

Anybody got any ideas?

Don’t just disable the old drives, pull them out completely (you can add them back later after Win 7 is up and running.) Ensure whatever drive you have left is master (if on ATA) or on port 0 (if on SATA.)

If you’re on ATA, please, please, please don’t have this on the same cable your DVD drive is on.

After those steps if you’re still slow, you may want to ensure your BIOS is okay and recognizes that drive as the correct size. You may even want to ensure your BIOS is up to date. During the install when you select the partition, go under “Advanced Drive Options” and kill any previous attempted partitions, then select the newly unused complete hard drive before continuing.

In reading your post though, I’m thinking this has less to do with Win 7, and more to do with that new hard drive not playing nice with what you already have, or not playing nice on your system entirely. The steps I mentioned above are just to hopefully isolate the drive away from the problem (if it’s caused by a conflict) and get you up and running. You might also want to use a pre-existing drive (if you don’t care about the data) and see if Win 7 will load on that okay.

Alright, I’ll give those things a shot. I don’t think it’s the new drive in and of itself (which is a SATA drive). The first time I booted from the CD that drive wasn’t plugged in yet, and it was still mega slow.

I’ll try updating my bios and running it only with the one drive.

Good luck sir. It may be the Windows 7 DVD as well, perhaps it’s having a hard time reading the disc?

Most of the times I’ve had issues with loading have usually been either a bad drive I’m writing to, a bad image that I burned of an OS, or in one case, a server BIOS that didn’t like the DVD drive I had just installed (though it saw it as a DVD, it didn’t play well.)

I’m guessing you don’t have a spare copy of Windows 7 or a spare DVD drive, so those are harder to swap out to troubleshoot. Let me know how it goes Gabe.

So. I decided I needed to go through my drives and do double back-ups of everything before I went any further. I formatted a couple of the old hard-drive partitions and updated my BIOS.

Also remembered that I’m actually running an MSI board and not an ASRock (that’s my second computer).

So the BIOS update had no effect on how Windows 7 boots. It’s still tremendously slow, although I did notice that if I run it a couple times in a row it’s a little faster each time. Trying to install to the new drive still Blue Screens at file Extraction.

I decided I needed to at least see if I could install to a hard-drive in general, so i took out the new drive and put the old ones back in and tried to install to one of the newly formatted partitions. I got pretty excited when it got through the entire File Extraction section without blue screening, but despair set in when it got to the “Installing Updates” portion, and stayed there for over an hour.

The mouse no longer responded. I left it on over night just in case (monitor off) and it was still stuck there this morning. What the hell?