Help me troubleshoot my 4870/PSU/MB

When I run anything that requires high end gpu usage, my display dies but my PC doesn’t turn off. The system fans keep running, and 1/4 of the time the gpu fan revs up to 100% until I shut the system off. I played through the entire main campaign of Red Faction and had one CTD (which was caused by incorrect memory timings in the BIOS). Now, it loads the menu, but when I load any saved game it crashes within 30 seconds. Red Faction is only one example. It ran Far Cry 2 for over an hour before it, too, crashed to black. A benchmark app like FurMark crashes to black as well.

No memory dumps that I can find and nothing in the event viewer. Windows thinks everything is in the green. The drivers have been clean reinstalled, but I haven’t run memtest yet. The 4870 is 9 months old, and the cpu/mb/ps/ram are one month old. I haven’t monkeyed with the BIOS settings beyond the initial setup to get things stable and a few unrelated tweaks. It ran like a blessed dream until yesterday.

What can I do to narrow this down before I call in an RMA on the card? I’ll update this as I perform additional troubleshooting.

XP SP3 32

Edit: Fallout 3 video is choppy at best, but gameplay appears fine. No crashes during 30 minutes of play.

Something on the card is overheating. I’ve had this happen on several ATI 48x0 series cards. When using a tool like GPU-Z to see what the temperatures on the card were, it was usually the MEMIO temp that was running a bit out of control and would usually lock up in the same manner.

Check your cooling in the machine, in general. You ought to have some good airflow going on. With that card, the aftermarket fan/heatsink combo shouldn’t be causing any issues. However, you may yank the sucker out and look to see if the heatsink(s) that are covering the RAM/memory IO controller are in-place/not loose (this is located under the shroud, on the end closest to the power connectors). I’m not sure how they attach on that board, might be that they are attached via screw, but perhaps not- sometimes, they are only attached via thermal goop or thermal tape, and if so, they can come loose. In any case, if nothing obvious looks wrong, RMA that sucker.

Your motherboard & power supply ought not be causing the issue here at all.

I’m inclined to agree. I ran gpu-v and here is the log as I loaded Fallout 3 a second time, started a new game, played the opening video, escaped out, then a crash to black. I am unsure as to the timings of each, but I do remember that it didn’t take 15 seconds before it crashed to black.

I had some free time at work today.