Help with SQL server

I have a running server for some time now, and now suddenly Enterprize manager doesn’t detect it.
I’ve tried re registering the server but I alwayes get an error message that the parameter is not correct.
Below is a shitty screen capture:

Can you see what I’m doing wrong here?

Is it running on the same machine that you’re running Enterprise Manager? If not, you could be encountering an authentication issue or network communications issue between machines. I notice you’re using Windows Authentication – which can be troublesome in times like these.

They are both running on the same machine.

I think even on a local machine, you have to have compatible network libraries set up on the server & client sides.

For the server, run the Server Network Utility (from the SQL Server program group on your start menu). You should probably make sure TCP/IP is in the Enabled list. Also look at the "Force protocol encryption’ option. Unless your network is a possible target for eavesdropping, you probably want that unchecked.

Now run the Client Network Utility, from the same program group. Make sure TCP/IP is enabled, and make it first in the list. The protocol encryption setting must match the server.

There are a lot of ways to configure those, the bottom line is the server and client must have a shared protocol & settings.

  1. Are you sure the sql server service is started?
  2. Try connecting to “.” without the quotes as the username.
  3. Try connecting from another server.

I enabled TCP/IP in the client network utility. The server network utiliy has TCP/IP also enabled and also Named Pipes :?:
“Force protocol encryption” is unchecked for both.
Still no good.

  1. Are you sure the sql server service is started?
  2. Try connecting to “.” without the quotes as the username.
  3. Try connecting from another server.

You can see the server icon in the tray. It’s working allright and my application can access it. I can also access it from Query Analyzer. The only problem is with Enterprize Manager.
I tried creating another server and another server group but it didn’t help.

Huh, that sounds like maybe Enterprise Manager got screwed up then. Try db backup/uninstall/reinstall?

Are there really SQL server issues than can require backup/uninstall/reinstall? I would throw a truly epic temper tantrum at Oracle support if they ever told me to do that.

It’s not so much the software as it is the shotgun approach to troubleshooting. Sometimes it makes sense. You can spend the rest of your life learning something as complex as SQL server.

Can you load up the SQL Server registration in just plain-vanilla MMC, rather than Enterprise Manager? Something may just be hinked with the registration of that attachment in the MMC.

Yeah, I’m thinking the registration for the MMC got screwed up. Try doing a client tools-only install on another box and connecting from there.

Ok I fixed it. I checked “Enable shared memory protocol” in the Client Network Utility, because I suddenly noticed that the error message I got had something to do with memory, and voilla. Off course I don’t have a clue as to what that means, but whatever makes it happy.

I believe the shared memory protocol is a super communication optimization when the client and server are on the same machine. Messages won’t actually flow through the whole tcp/ip stack on each side.

I didn’t know that it was required - maybe there was also some server setting demanding it for the local machine.

Strange. Not optimizing communication should result in slower performance, not an error message.

Well if that super optimization works as Tim says then you could still have something broken on your server. Since you’re bypassing TCP/IP you don’t experience the error. If the client does work from a different box then maybe the error is inconsequential and you don’t have to worry about it until the day that shared memory option becomes unchecked and you try to remember why the enterprise manager doesn’t work.