I HATE WIi7 "permissions" Ughh - can't delete my own stuff!

SO here’s the deal. Copy my boot and system drive over to a new drive. Install New OS on new drive and try to access old data. Even though I setup everything EXACTLY the same way, when I go to delete folders I’ve already copied it says I don’t have access to delete them.

How the heck does this thing work? I am the administrator, and I try and give myself dull permissions and it says “I can’t do that Hal”.


You have to ‘take ownership’ of the files first, and there should be a button for that in the advanced security properties.

Technically, when you retain old files from a previous install like that, they’re not “yours” anymore, they’re some other unknown user’s, since the new OS install would have assigned you a new, different security ID (it doesn’t just go by user name).

Select folders -> properties -> security -> advanced -> owner -> edit -> select your username, tick ‘replace owner on subcontainers and objects’ -> OK -> OK -> Close

I ran into this a while ago with shit that just WOULD NOT DELETE even with pwning everything imaginable. From what I remember subinacl was the answer and nothing else worked.

holy s—

you need to read these two articles, jp.

The first one s hows you the long way to do it.
The second one give you some registry hack you double click and after that you can right click on a folder to take ownership of it.


I already did that before posting and it said I didn’t have permission to change ownership details.

Honestly I just don’t get it. How can I install everything fresh, with the same userID, same version of Win7, everything identical and it still not recognize me? Both times I even had UAC off just to avoid this type of issue. I know they introduced this in Vista and it’s supposedly more secure, but I hate it.

Thanks for the articles LunchofKong & djotefsoup, hopefully I’ll find something in there that will work. I’m about ready to copy the data off and just fdisk it.

calm down, jeff, it’s nothing major.

hmm, missed that the regedit’s already been given.

If you have the same issue I did it might be simpler, there’s nothing wildcard that works for it that I found. I still have a couple of those files left (I got bored deleting them after I got rid of the ones that were actually causing me problems installing stuff), the .reg fix / take ownership thing in lunchofkongs link doesn’t work on them either. Has to be subinacl /onlyfile bla bla as mentioned in the last step of that KB article. The article references XP but it worked fine for me when I switched from 7 RC7100 to full 7.

You don’t have the same userID.

You might have the same local username, but that really isn’t the same thing as a userID, which is a good thing (in terms of security, if not convenience).

FWIW you would have saved yourself a ton of time & frustration by using Microsoft’s user migration tool, which exists to allow you to easily move data to new installs without having to worry about things like this.

Or use WET.
Windows Easy Transfer.

Windows Easy Transfer is the bomb. I discovered it on Friday when I copied my profiles to a new hard disk. That’s a really good Microsoft utility.