Immortals Fenyx Rising - Assassin's Cartoon of The Wild

He wasn’t right at the hall per se, but just outside on the green area for me. Just look for a ghost around the perimeter, on the grassy area of the plateau. I’m not sure but I think he was closer to the stamina upgrade bench.

Yeah, that’s where he was for me. And there was a new quest marker on the map anyway, leading to him.

Yeah not there at all

Nope no marker

Weird. Maybe it only appears after a certain point in the story? I was in a Typhon save…

I hard rebooted my console this morning which made me log in to the game again. It popped immediately on start. Now I can’t beat the enemies but at least I failed honestly =p

How the fuck do you jump this high at 3:20 to not need to jump on boxes first? There is no way. I double jump holding down to gain height but as soon as you kick into glide you lose 10 feet of air…

Didn’t notice anything special there, just an average double jump. Didn’t even seem to be a full double jump (longer hold of jump).

Not needed here but using ares wrath can help you quad jump for air, assuming you have enough stamina. Will be needed in some vaults.

Yeah I’m still on the 2nd island, only a bar and a half of stamina

Goddamn these devs fucking suck. Another game breaking bug that has been reported since fucking early december and they haven’t fixed it. I think I’m done.

Fix yo shit Ubisoft…

This game confuses the hell out of me (I’ve only played about an hour). I am fighting 2 enemies and it tells me I failed the navigation challenge. Hold a key to restart. I do. Fail again, not knowing what I am supposed to be doing. So I ignore failing, explore a little more, and now I can’t get it to activate. How to I get it to activate again? I go to the little pedestal thing and nothing happens.

Do pomegranates and blue mushrooms turn into potions at some point? Am I supposed to do something?

Should I just ignore everything and follow the story and it will eventually make sense?

I am finding stuff and doing challenges with no clue what am I doing. Is there a guide out there doesn’t give spoilers, but at least explains the little stuff?

Navigation challenges are races, or at least the one you were at is. You stand on that thing and a golden light beam shines off in the distance. Ignore those two guys and run as fast as you can for it (sprint). It took me a second to figure that out, too, since the game doesn’t tell you anything.

Poms and mushrooms do get turned into potions but you have to make it a certain distance into the story to unlock that.

I kind of figured it was, but after failing I went to explore. I got the power that lets me remove the obstacles from the “track” but the challenge is no longer activating. The pedestal is not longer lighting up, nor is the target in the distance. I tried leaving the area and coming back, but nothing is happening. Is there a way to reset the challenge?

No clue, I haven’t seen that happen, and I solved that challenge right after I got it (after wondering wtf for a minute).

It’s possible you may need to move forward and trigger some more story stuff. You got the bracers, but did you do anything more?

I got the bracers and just explored more. Went back to the track. Didn’t find anything significant.

I think I just need to play and come back later. Over thinking it I am sure. It’s my completist nature. I can’t find a locked door in and RPG and not get in.

Just be aware that there may be areas that aren’t really available to you, even though they are right there then, in this game. Thats because you may have to come back later on, with new powers.

Go to the start of the challenge and hold down the pause button.

Ahh that did it, thank you.

Enjoying the game quite a bit now.

So the first DLC drops today. No idea how it is since (as much as I’ve really enjoyed the game) I’ve got no interest in spending nearly as much for the season pass as I did for the game itself. Did i mention that season pass pricing has gotten really stupid bad? Borderlands 3 has this same issue.