Internet Gurus Needed!

Hey there.

For the past week or so, any “big” file I download seems to be corrupt. I tried downloading the Dominions 2 demo and Tron 2.0’s latest patch at least ten times apiece, and each time the file I ended up with would not install, citing the archive had gone corrupt.

Internet browsing is fine, no crashes/corruptions/problems. Multiplayer games are fine, no lag, pings of <70, etc. It’s just these “big” downloads seem to have a good chance (85%+ I’d say) of going corrupt!

I’ve done a surface scan of my HDD–no bad sectors. I’ve installed things from my CD-ROM with flawless transfers. I even tried a low-level format/reinstall last night… no beans. I’m still downloading corrupt files.

Really my system has no other problems than this one. It’s rock-solid, especially after my format/reinstall last night (my last install was developing some OS rot). If this one thing was accompanied by a litany of crashes or CD-ROM based install problems, I’d assume a bad IDE cable, bad RAM, or even a bad CPU. But it’s not. The system is fine besides this.

I’m not running a firewall (except WinXP’s default), nor any anti-virus (yet), so neither of those things could be corrupting these downloads (unless it’s WinXP’s default FW). In fact, the only “weird” thing about my system at this point is the fact that my cable modem is constantly “busy” with traffic, even when my system is off or idle. It’s been like that before and after the low-level format/reinstall–so I don’t think spyware or a virus/worm is the culprit (though who knows…)

Could this recent solar flare storm be the cause? Is this more of my ISP’s (Comcast’s) issue than mine?

Could it have something to do with large file creation?

Try copying a really large file on your drive that you know is intact, and see if the copy gets corrupted.

If so, try turning off DMA on your hard drive and see if that lets you downloads go through.

I actually had a problem like this once… on an Amiga 4000. Files over a certain size were getting corrupted by the file system because it couldn’t keep up.

If turning off DMA does help, I’d look at re-routing or replacing your IDE cable to see if that helps.

(This may not be it… It’s just what comes to mind at first.)

This is a totally wild-assed guess. Are you using any download “accelerators” that may be pulling in chunks of files but not reassembling them properly?

Have you cleaned out your Internet temp files?

Nope. Not before, and certainly not after my clean install. :(

Well, if a format/reinstall counts… :P

Seriously though. After my format/reinstall last night I visited Windows Update then after SP1 + other misc. patches were done installing, visited nVidia to download drivers for my GF3. The first time I tried downloading the driver pack, it was corrupt. After a try or two, however, I got a “good” copy. SO, the Temp Internet folder wasn’t totally clean, but it wasn’t stuffed full either.

I did try clearing the folder prior to my format/reinstall, and it had no effect then.

It very well might… I can test this when I get home. I’ll post the results when I can.

No beans. I tried copying a ~16MB file from a CD to the HDD–ran flawlessly.

I downloaded a ~4MB file, it was corrupt.

Anything else?

Running a RAM test now… a Google search revealed a couple others with this issue which bounced back to bad RAM.

Eep! Bad RAM! Time to figure out which stick it’s on…

Interesting problem.

Problem solved. One of my 256MB sticks had gone bad. Once I removed the bad one and restarted, I downloaded files just fine. :D

I wonder if I should format/reinstall again just to be safe, despite my lack of problems…

Well sure. As a computer hobbyist, you should be regularly reinstalling your operating system just for the hell of it. In my case, I reinstalled Windows ME 4 times. It brought me no end of joy.

Well sure. As a computer hobbyist, you should be regularly reinstalling your operating system just for the hell of it. In my case, I reinstalled Windows ME 4 times. It brought me no end of joy.[/quote]

I’ll take that as a no. :P