LAN adaptor/internet problems/"unidentified network" problem

So I’m finally fixing up my primary desktop after a HD crash. I put in a new SSD drive and a clean install of window 7 home 64 bit, and have left the other (broken) HD installed in order to try to transfer whatever data I can salvage (with decent success - got all my documents and pictures, at least).

But I’m having a weird network adapter issue that seems to have generated a lot of online discussion but I can’t find a fix – my PC doesn’t automatically connect to the internet through its LAN connection – instead it just sees an “unidentified network” and can’t connect to the internet. More info:

  1. if I go to network settings and use Microsoft’s troubleshooter, it will “reset my local area connection” and that will fix the problem – I will be back online and everything will work fine…until I reboot/restart, at which time the same problem will persist until I run the troubleshooter again.

  2. I also have a wireless card in my PC - it connects fine, and will merge its connection with the LAN one if I run the troubleshooter as described above. In case it was causing problems, I’ve disabled that network adapter, which doesn’t really do anything except take away the wireless connection. I still need to run the troubleshooter to connect by LAN.

  3. I’ve tried disabling the Network adapter for the LAN and then reenabling it - I’ve tried updating the network adapter driver. I’ve tried going to a command prompt and releasing IPs.

  4. I’m using a dlink DIR-655 router - when I go into the router settings, it has my computer listed twice under “LAN Computers” (that’s after disabling the wireless adapter). Could that be a problem, and if so how do I delete remove the second entry?
    i.e. it’s list under both of these IP addresses
    192.168.0.169
    192.168.0.197

Could it have anything to do with having the old HD still attached to the PC (with its own windows installation)? I don’t think so, and am still salvaging data anyway.

Help!

This is sounding suspiciously like router flakiness to me. Try writing down the important settings (like wifi keys), doing a settings wipe on it and setting it up again.

Yeah, that’s what I thought too – seem to have fixed it – I think the “dual entries” point was unrelated and perhaps just reflected that the lease hadn’t been released from the prior setup? That resolved itself in a day or so, bu the problem remained.

I ended up just fixing everything I could think of on the router and adapter - updating drivers/firmware, factory restarting the router and my cable modem, and something in that shotgun approach seems to have worked, as it didn’t happen when I last rebooted.

Weird quirk for sure, but seems to have generated a fair amount of discussion online, with various theories/software conflicts proposed (apparently the Bonjour service, in particular). But as I was working off a clean windows reboot it had to be something basic.